Custom fieldsnot printing

I added a couple of custom fields to my invoices and my sales quotes, orders. At first they were printing on the quote, order invoice, however after the latest updates they have stopped printing on the selected item. I know this was an issue back in 2015 but was to be corrected then and seem to have been. Why has it reappeared?

When you create/edit a custom field, there should be a checkbox “Display custom field on printed invoice” or something like that… Have you tried enabling that check box?


Tried it with it checked, with both boxes checked, with neither checked and
with only one checked and it still has not started to show on the forms. As
I mentioned it was up until the latest updates.

Thank you

Robert Jacobi


Forgot to mentioned that when I view the quote, order, invoice I can see
the custom field, it is only when it prints that I do not get the printed
version of the custom field.

Thank you

Robert Jacobi

Are you printing with the print button or generating a PDF and printing that? Also, what operating system?

I have tried to print from both the print and the pdf and I get the same result. Using windows operating system

I just upgraded to V 21.1.30 and am facing a similar situation - in my case, neither are custom fields printing nor are they visible on screen.

Using Windows 10 Any suggestions as to how I can resolve this?

@Sokoni_Advertiser, post a screen shot of the Edit screen for a custom field you believe does not show as it should.

Also, do the fields have content entered into them? They will not show if they are empty.

As you can see, notes have been set under settings, but not showing in the doc.

The Description field in the Custom Field edit transaction is a field to describe what the custom field is used for not to hold the information which appears on printed documents

The default information to be held in the custom field is entered in the Default Settings for the document. It can then be edited when a new document is created

Please read the guides for clear instructions

Thank you very much, issue resolved.