DESKTOP EDITION CLOUD EDITION SERVER EDITION GUIDES FORUM

Custom field on printed document issues


#1

I have 2 inventory item custom fields enabled for printed documents.
They show on my Purchase Invoice, but only 1 shows on the Sales invoices.
I especially want them to show on the sales invoice, I dont really want them on my purchase invoice, how can I do this?

Also they aren’t added to the document in the position I have specified. In the inventory items tabs they are, but not in the printed documents.

I use the default template.


#2

First, a custom field will not show if there is nothing entered in it. This avoids a heading with nothing below. So, on your sales invoices, is there content?

Custom fields for purchase invoices and sales invoices are unique and are defined under different headings under Settings => Custom Fields. See the Guide: https://www.manager.io/guides/8941. A purchase invoice custom field will not show on a sales order, and vice versa.

What and how did you specify position, and what was the result? Show a screen shot.

If you defined custom fields for inventory items, they won’t show on either purchase or sales invoices. Again, custom fields are unique to the form they have been defined for.


#3

The custom field data is entered, and I haven’t created anything for either the purchase invoice or sales invoice.

Here is what I’ve created:

I ticked the show in printed documents checkbox for 2 and 3.

This is the inventory, everything is in the right order.

This is the purchase invoice, the columns dont seem to follow position order?

This is sales invoice, only one of the column is showing unlike the purchase invoice… why?


#4

I cannot reproduce your problems. I added your 4 custom fields, with all designated to show as columns and #2 and #3 to show on printed documents, then created an inventory item for one of your books:

19 AM

34 AM

Everything appears in order. I add this inventory item to a sales invoice:

The two fields designated to appear on printed documents are there, and in the order specified. I next add the inventory item to a purchase invoice:

Once again, I get the two fields that are supposed to show, in the correct order.

What version of the software are you using (under About Manager)? Current is 17.7.67. Update if you are behind and see if the problem is fixed.

As for your desire to have things show only on sales invoices, that is tougher. It would take some relatively sophisticated programming in a custom theme to have fields associated with inventory items only show on one type of form. What you might do is use sales invoice - line custom fields. But that would require you to enter their contents manually on every line. Line item custom fields cannot be associated with inventory items to be remembered. It’s probably better to live with the two unnecessary (but not incorrect) columns on purchase invoices.


#5

I am behind, how do I update the software on Mac, please?

As for your desire to have things show only on sales invoices, that is tougher.

Yea I will live with it, it’s not an issue anyway. :slight_smile:


#6

you just have to download your required platform and install it on top of your old version without uninstalling it.
https://www.manager.io/desktop/download/


#7