DESKTOP EDITION CLOUD EDITION SERVER EDITION GUIDES FORUM

Custom Field on Sales Invoice


#1

Hi, i started to use the custom field on our Sales Invoice. However, it seems something is not ok here. I made the custom field but due to some reason i cannot see it on the document?

any idea, help on that?


#2

From your images it looks like you have created your own template for sales invoices. That’s fine but then you will have to add custom fields yourself to the template.

Custom fields can be referenced by name like this: {{ custom_field_name }}

Good luck.


#3

Hi @Hans, no i use the current template, not a own one due to i have no idea on html, so just use the current template

Dietmar


#4

I have never seen the text “THANK YOU FOR YOUR BUSINESS !” on the default template.
You can check what template you are using when you create new sales invoice (at the bottom).
If the dropdown list for template is empty, you are using the default.


#5

It is the default template. I never do something others here.!

to make this “Thank you…” you can use the notes then write it notes as pic attached" if you use f.e. USD - Bank Konto Information: this text will show BOLD text in printing documents.


#6

Got it; the boxed border around the text is what confused me. I don’t use the notes field.
Leaves you with the problem that starts to look like a bug. I will do some test after work.


#7

Hi @Dietmar

I created a new custom dropdown list for Sales invoice with the Show custom field as column and on printed documents checked. Then I created new invoice and could use my custom dropdown. Made sure the View template field was empty, saved it and viewed the Sales invoice, and as expected the dropdown was there.

Since custom fields are placed at the bottom of the invoice I still think it has something to do with your notes field. Maybe you can try removing it.

Also can you explain a bit more about: **write it notes as pic attached" if you use f.e. USD - Bank Konto Information: this text will show BOLD text in printing documents.**


#8

Hi @Hans, thanks for feedback. I tried several times, also removed the notes field. All not ok, I have the custom field in Sales Invoice, can choose what i need but don t see it then on printing document. Also, I removed my notes and tried again but also still not on printing documents. Now i tried the same on Purchase Invoice but also here cannot see on printing documents

for other issue you want more info. For example, if you write in notes BANK INFO… the this will show on printing document as normal font. If you write in notes BANK INFO, then the font will be bold. Just use the ** in front and end of text, hope now more clear


#9

Hi @Dietmar,

So even though you don’t use HTML, you do seem to use Markdown (lightweight markup language).
Like this for italic or bold. Also there is a lot of space between the total amount on the invoice and the “THANK YOU” text box. The default template puts the notes field directly under invoice line items (see picture with dropdown)

Since it works for me I can only suggest you create a new business and call it something like Test or Demo and create your dropdown list. Then create invoice, leave template box empty, and check invoice.


#10

Hi, ok I made the test company and checked. Then i found out all is fine and working as i would need it. (see pic 1)

then i go back to our company and checked again. After careful check and compare with test company i found out that in the field VIEW TEMPLATE there was marked My Template. I don’t know why and how this happened. Anyhow i took this out and now all is fine (see pic 2)

thanks for support, finally seems this is solved

Dietmar


#11

HI, regarding adding custom field to sales invoice, what should the html code look like to point to that label / data?
example, customs field in “Sales Invoice” call “Weight”


#12

Hi @Dietmar, I am glad all is fine.

For @comspal see quote for syntax.

Also have a look here: http://guides.manager.io/businesses/settings/view-templates/sales-invoice-variables


#13

hi, tried different way but still can get the custom field showing up on the template, where am I going wrong?

div>Number of Cartons: {{ sales.invoice.custom_fields_Gross_Weight }}

Gross Weight (Kg): {{ sales invoice.custom_fields[‘Number.of.Cartons’] }}

#14

First, when you edit custom field, make sure the option Show custom field on printed documents is checked.

Then in your HTML template, you can inject the content of custom field using this syntax:

{{ custom_fields['Number of Cartons'] }}

Or just don’t use custom HTML template and the custom field will show by default.


#15

Got it, THANKS :smile: