Copy to clipboard not working on Ubuntu

Using Ubuntu 20.04 LTS and latest version of Manager Desktop 21.2.83, copy to clip board is not working

Where in the program? What are you trying to copy?

I am trying to
1 copy inventory to excel
2 batch update
3 batch delete
4 batch create

Also there is new problem which I noticed today that
Code is also being displayed in description tab after pdf generation.

Do both uses of the Copy to Clipboard function fail? How? What happens?

Batch Delete does not involve any copying.

Again, exactly what happens?

Please do not mix problems in a single topic. Start a new topic.


Both Copy inventory & Batch Create function fail.

Nothing is copied to clipboard for both functions above, the problem is with Kde Neon,(Thought it was problem with K

DE) and switched to Ubuntu but problem is same.

Tried to paste in text editor and excel (calc on libreoffice)

Running 21.2.74 desktop version on Ubuntu, I can confirm that the “Copy to Clipboard” buttons appears to be non-functional when working within Manager. The button text does not change to “Copied” and the clipboard is not loaded with the data.

Happily there is a workaround for this issue, which is to open the page in a web browser, where the button works fine.

Thanks brother, but this BUG needs to be fixed in next issues

Try updating. The version you mentioned is almost 20 versions behind.

Still not working in Linux Desktop v21.3.3

upgraded to 21.3.6, still not working…

The Clipboard API in the web browser requires https secure access. The windows and Mac clipboard API also allow http access from the local host. Perhaps this is not the case under Linux.

Have Linux desktop users

  • tried opening a Manager link in another browser (their desktop preferred) and see if the issue persists.
  • I assume access from the Linux desktop browser to a Manager sever on Linux over https works OK.

The Problem is with desktop edition running, and accessing it on same desktop.
The COPY TO CLIPBOARD is not working in manager window but works when opening manager in Firefox

1 Like

Hello I also have the same issue on UBUNTU. I am running 21.3.53, and would like to be able to send my accounts over to my accountant without it being a PDF. I click copy to clipboard and nothing.

The older version had a window where you could just copy the text over; where did that go? Also i hear that i can open it in a browser, how do I do that as I have the desktop version.

Its OK I have solved the issue.

You have to open the link in a web browser.

@lubos … Kindly look into this matter. The server version can copy to clipboard in browser quite alright but only on the computer adopted as a server. Any other computer can’t reproduce the copy to clipboard functions in browser. As you may know not every user do their works on the server computer. And as such they are required to generate some reports in excel. In my case, no user including myself works on the computer allocated as a server. All computer users are connected to the server computer to avoid corrupting the data. Please assist on the way forward. Its really a matter of urgency as we are two months behind schedule with our reports. We are anble to do reports in excel.Please help.

although the symptoms are similar this is a different problem to that being discussed in this thread. See

You have to provide https access for all server installations not just publicly accessible servers. See this post for how to do it Bug with "Copy to Clipboard" - #69 by Patch

@Patch. Thanks for that but you know I am just an Accountant in love with this accounting software because it is simple to use. But when just exporting data to excel becomes technical makes some of us with little knowledge in programming helpless. Envolving an expert in matters such as this is proving expensive rendering this software expensive too. I wish i could simply copy data and paste like before the clipboard came in. I am not sure what has to be done from here. This tool is very important. I believe something can be done for some of us, like myself.

Ask your IT support for help.

This is why the Cloud version is often better for businesses without the technical expertise to manage the server version.

These are the responsibilities you take on when you decide to use the server edition instead of the cloud edition. The clearly stated presumption is that you have the skills and resources available to properly install, operate, and manage a server installation. When that is not the case, you have probably chosen the wrong edition for your situation.

From the Guide:

I dont get it. Why would something that was working alright be changed in order fix us that did not choose the cloud version. It sounds like a marketing gimic to force clients to a cloud version. I spent money on this too remember? Its not free and I still have access to one year free updates so what are saying.