Converting xls to file types compatible with manager

I need help in converting a bank statement which is in excel (xls) format to any file type readable by Manager so that I can do a bank statement import into manager

Why don’t you use batch create directly from Excel?

The only format you have any hope of converting an Excel file into is .csv. The other statement formats all include prescribed codes and formats not compatible with representation in spreadsheet formats. Techniques for doing that depend on your operating system and version of Excel. Check Excel Help. Whatever process is required, you need to have the five columns described in the Guide: https://www.manager.io/guides/9240.

I’ve given up on importing a csv file. I always receive the message:

image

I’ve just created a new sample file and again it doesn’t work. I don’t know why. The contents of the sample file is:

image

What’s wrong with it?

Enter some manual transaction into manager and then export them and you will see the format your installation requires

There aremany things that coyld be wrong Date format, character set, …

The most common issue is date formats. The .csv file must be in the same “visual” format as Manager’s date preference. But it should not be a date-formatted cell in the spreadsheet. If it is, the date is actually stored as an integer, numbering from the date origin of the spreadsheet program, which can vary by operating system and preference settings. It is only converted to a sensible date format for display. Financial file formats should be plain text.

Why? The guide mentioned by @Tut states the necessary contents.

Yes, but it does not mention cell formats, because then you get into tutorials on spreadsheets, which is not its purpose. The fact is, the developer wanted to do away with .csv files a couple years ago, but too many banks offer nothing more sophisticated. And some don’t even offer those. The fact is, they don’t care whether you can import their statements into financial programs.

Not only they don’t care, a lot of them would prefer you used whatever tools they are providing although any of the bank supplied tools I’ve seen are useless

OK, I converted the date into text but nothing. I give up. It simply doesn’t want to import and I guess the OP (and others) encounters the same problem.

BTW, the guide only indicates about the Date: ‘be sure format matches your selection in the Preferences tab’. So what is meant with format? It doesn’t specify that it should not be in date format in Excel.

Again, why don’t you give “batch create” a try?

my scv looks like this and no problem at all.
We using Date format 05.06.2020

Clipboard01-manager-csv

That did the trick. Thanks. I guess the guide needs to be updated? (BTW, @Tut , Excel date column formatted as custom date dd.mm.yyyy :wink: )

OK, I’ve done some more tests and it seems that (in my laptop) all date formats starting with the year won’t import. Could someone confirm this?

in your csv file date must to be allways - dd.mm.yyyy ( 25.06.2019 )
but you can change manager date format to any format and manager shows then correctly

Clipboard01-manager-csv-3

Well, I’m able to import dd-mm-yyyy and dd/mm/yyyy too, and also mm-dd-yyyy and mm/dd/yyyy. The only date formats that won’t import are those starting with the year. Weird.