Business not opening after update

Hi,

I installed the latest version of Manager (desktop version).
I can open the program but I cannot open my business.

I reinstalled it, restarted the computer, used the repair option… Nothing works. I’m running out of options…
I made a backup before I made the update so I tried adding that with the option “new business/import backup”. The backup then shows in the list with businsess but nothing happens when I click on it. I don’t get an error message. It seems to block. The buttons on top work, it only blocks when I click on a business.

What more can I do? Can I go back to my previous version?

Thanks if you have an idea.
Tinneke

You cannot go back to a previous version unless you saved the original download when you installed it. And you cannot open a data file with the older version if you have already tried to open it with the newer version.

One problem you have is that you seem to be creating a new business for every year. This is not the correct approach. Manager is a perpetual accounting system. See this Guide for year-end procedures:

https://forum.manager.io/t/closing-an-accounting-period-in-manager/7470

Your problem of not being able to “open your business” must be described in more detail. Does anything happen when you select a business? Do you see a few default tabs but no real accounting data? Your statement that “nothing happens when I click on it” seems unlikely.

Can you post a screen shot of the information that appears when you click ?

Hi
Thanks for your reply!
Although it seems unlikely nothing happens when I click on the business, this really is the case. I don’t get an error message. Nothing happens as I described above. I just see the screen that I already posted so I’m afraid I don’t have any other screens to post. After I click on the business, all the other buttons are also blocked and I can’t click on anything else.

I can create a new business and open the new business. I just did this as a test to see if that worked . But what I would like to do is open my existing business and that doesn’t work.

So are you saying that when you click on Over Manager (About Manager in English), nothing comes up? That contradicts what you wrote earlier, that the “buttons on top work.”

What I am trying to see is the path to your application data. If you can determine that, I wanted to see the directory for the application data folder. Your problem shows signs of being caused by the program looking in the wrong place for accounting data. This could happen if you changed the default location or moved files. Some files are automatically recreated according to a separate data base in the newest versions. So although you may see businesses listed, they may not be connected to the actual business data files. It can be complex. And depending on how old the backup files are that you are importing, different problems could result.

You might look at this Guide, too:

Hi,

Thanks for your reaction.
The buttons work before I click on the business. After I click on the business everything blocks.

I made the backup yesterday before the update but I still used an old version of Manager.
I always used the default locations but I will check the link you sent me because data storage might have changed if I understand the guide correctly.
I will try to do what the article describes and see if that helps. Thank you