DESKTOP EDITION CLOUD EDITION SERVER EDITION GUIDES FORUM

Bug When Generating PDF under General Ledger Transactions


#1

When I try to generate the pdf under general ledger transactions, it takes ages and than I get this message:

My version is 19.1.28 (error persist also with 19.2.38)


#2

504 Gateway Timeout means the server took too long to respond.

Some questions:

  1. Which edition of Manager are you using: Desktop, Cloud or Server?
  2. Does this happen for all PDFs, or just certain invoices etc?
  3. What happens if you click the other button instead - Print vs PDF - does the PDF finish generating in that situation?
  4. When did this start happening? Was it immediately after an upgrade to 19.1.28? The latest is 19.1.38 (as I write this) - does it still happen if you update to that version?

Not sure what else to ask, but that’s probably a good starting point.


#3

Server edition
Only with general ledger transactions
Only with PDF
It happens only with a new business we created a few months ago. First time I tried this report on this one. With the other one it works
I try to update


#4

Same error with 19.1.38. It’s a bug.
Print works so, as a workaround, I can print to PDF.


#5

What happens if you back up the business and restore from backup. Does the new business file also have the issue?

Perhaps there’s a bug related to missing information. For example, have you uploaded a logo and other business details? That shouldn’t cause any issues if they are blank, just thinking of what might differ between this business and your more established one.


#6

General transaction ledger doesn’t have any logo nor any additional information. It doesn’t even use themes. I think it’s something related to the large number of lines, ie it’s a bug and needs to be solved.


#7

I created a G/L transaction report with all my transactions - it took a while to do but it did create the PDF with 95 pages without a problem.

But that’s not a lot of transactions, I’d guess

Using Windows 10 Desktop version 19.1.34 -Microsoft Edge browser


#8

It looks like you are using Chrome. Try a different browser. Many users have reported problems with Chrome that disappear when using other browsers. Although why this would occur with one business and not another is beyond me. Nevertheless, knowing whether Chrome is the problem would be useful.


#9

Same problem with explorer.


#10

Could there be a corrupt transaction?

can you try different dates to see if some work and then narrow it back to a particular transaction or does it not work at all - even for 1 days worth of transactions?


#11

It can be but since there are so many transaction it would be impossible. Keep in mind however that the report is generated. It just doesn’t save in PDF. So for screen and printing there’s no corrupted transaction.


#12

Maybe there is a bug. But until you can identify what is different between a business and report that works and one that doesn’t, it cannot be fixed.

It would not be difficult to isolate a transaction causing the problem, if that is what it is. Edit the date range so it covers half the period, then the other half. If that doesn’t isolate the problem, it isn’t a corrupted transaction (unless you have the same problem with more than one). If one half works, cut the other in half again, and so on. If both halves work, it’s probably the length of the report.


#13

I’ll try it. Thanks @tut


#14

Ok… I divided the report, which was from 1/7/2018 to 31/12/2018, into two reports: 1/7/2018 to 30/9/2018 and 1/10/2018 to 31/12/2018. Both were generated successfully.

However if I increase the date range of the first report from 1/7/2018 to 31/10/2018 I get the usual error. So the problem definitely the length of the report. Maybe @lubos can increase the memory buffer dedicated to this task or find some workaround. It seems that the internal pdf generator of Manager is very angry of resources.


#15

Good information. I have moved this to the bugs category.


#16

Thanks @tut. As it happened in the past if @lubos needs it I can send him the backup file to see what was wrong.


#17

Oh, I’m definitely not disputing that it’s probably a bug. Just trying to dig into what might be causing it / find a way to reproduce it, as if it is a bug that’ll make it easier for lubos to correct it.

Edit: Looks like a likely cause has been found.


#18

Can you try the latest version (19.1.40) ? It should be faster.


#19

hi @lubos, I tried it but I get the same error.


#20

How long is timeout on your nginx server? This is not bug in Manager, the error is from Nginx server. I’m aware that for very long reports, PDF generation could take over 60 seconds which I suspect would be Nginx timeout. Try to connect to Manager Server directly and see how long does it take to get PDF.