Billable expenses--field not showing up any more

I updated Manager, and now a field labeled “Description” is no longer showing up on my Billable Expenses default form. I can’t seem to get it back; the only thing I can do is find an old form that has it and clone it. I really need this field.

What am I doing wrong, or is this no longer supported? If so, why? It’s very useful.

Thank you!

Next time please give full info about which version you are using because I updated Manager doesn’t say anything. Also if it’s Desktop, Server or Cloud and what OS you are on. And it’s recommended to post screenshots to make things clearer.

AFAIK there isn’t any Billable Expenses default form but I guess you are referring to the Edit screen? If you look well, you can see there’s the Line description tick box and by ticking it you’ll get the line description entry field.


You can edit the form defaults in Manager → Settings and activate line description as shown by @Mark for each form (such as Payments) to record Billable Expenses. In such case the “Line description” will always appear as default whenever you record a Billable Expense.

There is no form for billable expenses. Billable expenses are recorded via either a purchase invoice, expense claim, or payment form by selecting the Billable expenses account for posting. @Mark and @eko have addressed their correct use.