Description not visible of invoices

I’ve noticed that a recent change has occurred to invoices.
I can no longer add an item / services description where I used to be able to.
I don’t have items setup as I sell services which are customised per project / client.
I understand that I can copy a sales order to an invoice but it means that the description bought across from the sales order is copied to the invoice and is unable to be edited. Screenshot below which shows a blank invoice. The description used to be between item and account.
Is there a way of overcoming this?

My edition of is 21.3.95 which is the cloud version. The above issue appears to be a very recent change as this wasn’t the case last week.


click on “line description” below the add line, the column for description will appear. You can make this permanent in settings->form defaults->select the forms you want this to be applied to->click on line items.

Next time please search the Forum for this as I already provided similar answer to similar Forum post.


Thanks for your comment and guidance. I’ve added this as a default option now so hopefully that will overcome the issue moving forward.

Also. I did search the forum, as i always do before posting, and didn’t find an answer to my question. hence the reason I posted.

I can confirm that this bug is still there on version 21.3.97.

It seems to be a byproduct of the new hedious invoice format that some users insist on shoving down our throats based on their uneducated views on what a proper tax invoices should include (but I digress).

For businesses with no tax, it’s business as usual:

But for businesses with tax, you get this eyesore missing the description:

What has this to do with the problem that was not a real problem and was fixed? This seems to be a new unrelated topic, so why add it here?

The display is a REAL problem, it is confusing, redundant and excessive. I don’t want to look at tons of inconsequential calculations and hide the descriptions. I want to focus on a small set of highly important information.

But if you just click on “line description” below add line thnn the problem goes away and if you want to have this checked permanently so it appears all the time you need to change it in settings->form defaults->select the forms you want this to be applied to->click on line items.

Descriptions are important and they are not trivial in the sense that they can be calculated from other fields like the inline tax calculations.

Yes, I agree and that is why you can enable them, do not see the problem, sorry!

It’s OK

It is not a bug. It is a feature that was added to benefit those with smaller screens or whose item names provide all the description that is necessary. And it can easily be controlled in Form Defaults.

1 Like

I realize my mistake now. Thanks @Tut and @eko.