Bank Statement Import brings false figures


Hi there. This software seems awesome and it should be exactly what I need.
Yet, there no way I managed to make it work properly. I tried to import my banks statements (tried with csv, qif ofx) but each time I got the number to be like 95.00 instead of 0.95 or 12 290,00 instead of 122.90

I downloaded the lastest version on thos website, I work on iMac with Sierra (not Hight Sierra)
I tried to change the number format before importing, no result
I tried to change the number format in the Mac Preferences and then tried again to import, no result.
In fact, I spent the whole afternoon trying to find the right combination but I never managed to make if work.
(Should I add that I tried to import the same .ofx in a different software and it worked with no problem)

Does anyone has the solution or should I just give up?


Examine content of the file from the bank with TextEdit to see what the bank’s export format is.


Hello Tut
Thanks for answering me. I did actually (I should have tell first)
The QIF number format is like 1000,00 or 0,99 or 100,00
(I’m not rich enough to know what happens after the 6th digit :frowning: :sweat_smile:

The point is, there is no number format in Manager that match it (there always is a space between the 4th and the 3d digit in Manager).

Anyhow, as I said I tried each number format one by one with no result.
Should I try to change the number format then close and restart Manager (and even the computer) ?
Thanks for your help.


You can try that, but I don’t think it will make any difference.

The problem seems to be that your bank’s number format uses commas as decimal separators but does not use anything as thousands separators. Manager has no such format. But your first post confused the issue, because you wrote that you were getting commas instead of dots as decimal separators.

So a question: what number format do you actually want to use? And can you provide an example of that format and what the import process is giving instead? Then, can you also show what one of the exported statements shows for that same number? (Your two posts gave completely different examples.)

Now, something to try: use TextEdit to modify the export file to include spaces where your preferred number format has them and see if that corrects things. If your bank uses a hybrid number format, you may have no choice but manual editing before import.


Hi Tut
Thanks a lot for your answer.

I’m sorry you did not understand my examples. Probably because as I said, I tried each number format available but none of them worked. And it is the point of my examples : not that I was getting commas instead of dots as decimal separators but that the decimal separator was misplaced not matter what number format I was using, either with dots or comas.

Here are the answers to your questions:

  • My bank uses a number format like this: 2401,56 (example 1) or 0,95 (example 2)
  • When importing in Manger I get instead: 240 156,00 (example 1) or 95,00 (example 2)

What is confusing is that I do have one bank statement that contains only amounts under 900 euros. Theoretically, it should work properly with either of Manager’s number format that uses comas as decimal separator whatever the thousands separator, right?

The bank number format for that is like “900,00”. So it uses comas as decimal separators.
Yet, that specific bank statement brings the same issue whatever the number format I use: I get 90 000,00 instead of 900,00

To put it this way: the thousands separator can’t be the issue here (even if I can confirm that my bank’s number format does not use anything as thousands separators: 2401,56).

Not being able to import those statements is even more frustrating knowing my bank is not a mere local bank with some obscure number format but the worldwide HSBC and I can’t see why manager can’t import HSBC’s statements. And anyhow, it’s useless if I first have to manual edit every .qif I need to import.

Manager seems a great tool, but for now I can’t use it because of this little issue.
Any idea?
Many thanks


Sorry, but I don’t know enough about either statement formats or how Manager handles their imports to suggest anything else. I can only tell you that, in four years, I don’t recall anyone reporting this problem. I will invite @lubos to join this topic.


Hi Tut
Thank you anyway for your help