Bank statement import ignores amounts of 1000 or more

I have recently started using Manager and ran into an import problem that I couldn’t find anyone else mentioning:
I imported from .csv format (unfortunately the bank statement was only available in that format), but found that every amount exceeding 1000 (deposit or expense) was ignored by the import function. I thought it might be because there is a space between the '000 and '00, but there was neither space, nor comma. Am I doing something wrong?

What version of Manager are you using?

Can you post an extract from your csv file?

Also what settings are you using for Date & Number Format?

I have just downloaded the latest version for a 32 bit OS, but the bank statement import was done 3 days ago, also after downloading the version available then (don’t know if there were any updates since then?)
Date & time settings:

Number settings:

Screenshot of .csv file (after opening up the columns):

Please show the date and number format in Manager settings not Windows. Make sure the date in Excell is in date format (not text) and make sure it is a CSV file (you mentioned it is). The latest version can be found at Releases · Manager-io/ · GitHub The 32bit version is

Apparently, the csv file saves the number as a text string because it contains a space character.

What you can do is clear formatting on your amount column in excel before saving to csv. The shortcut for that is Ctrl + Shift + ` or Ctrl + ~ if you have a separate key for the tilde character.

Request that your bank support other protocols. CSV is the most unreliable import format to use. I use OFX and never have any issues.

@Ealfardan is correct. But I will go further. It appears that none of the entries in your Amount column are in number format, since the number of decimal places varies.

The sum of all comments points to this being a format problem with your statement file, not an issue with Manager.

I meant a copy of the text csv file, not the data in Excel which has formatted everything using its own setting.

Use Notepad to open the csv file and see what the imported data actually looks like

1 Like

Your date formats are a bit all over the place too - two separate settings in the Windows setting, a different one in Excel - I’m surprised anything was imported correctly at :slight_smile:


Lol! Well,paint me purple and call me Barney! I didn’t notice the date and number format settings in Manager :smiley: Thanks!
They were blank, so I set them to how they appear on the .csv file, but that did not solve my problem.
The date column is set to the correct date format, but it still only imports small amounts.
I should mention that I had to improvise on the bank statements since I did not originally have them in .csv format. I copied & pasted them from my bank statements that I only had in PDF format into text on Notepad, then manually replaced existing commas with spaces. I then entered the commas for the puposes of “.csv” before importing them into Excel and saving it in “.csv” format. This worked beautifully, but now it seems that the spaces I entered might have influenced the importing. I will have a look and revert.

The data you see in Excel is not the format of the data in the csv file. Excel reformats it when it saves the file as a CSV file.

That’s why it is important to open the csv file using Notepad or some other simple text editor to see the real format of the data

1 Like

That will never work, we have several banks and they never listen to us ever.

My Goodness! You guys were all over it while I slept last night :smiley: Thanks for the excellent response!
Just to clear the air: I did not think the propblem was with Manager - I expected I might be doing something wrong (some people need to pay the “school fees” to learn).

I left the bank that I needed the correct version of my statements from and wasn’t willing to pay for obtaining statements from them, so I improvised from the ones I had :slight_smile:
As promised I removed the spaces in the amounts on the text file before importing them into Excel to save as .csv (opens in Excel by dafault on my computer) and that solved my problem.
Thanks a lot for the help, everyone!