Backup problem with Chromium-based browsers

Hi, I’ve just tried to backup, as I usually do on Manager by clicking on the ‘backup button’. Today, instead of being asked where to save my file to, I was show a screen with the backup file name and a list of options to tick, as in this screenshot


When I click on the backup button on the bottom of the new screen, the button seems to grey out and nothing happens. I’m not asked where to back the file up to and nothing seems to happen. Is anyone else experiencing this problem? It worked as it usually does just yesterday evening, without showing me this new screen and I can’t see any mention of it in the latest newsletter. Thanks

I cannot replicate this behavior. The very first time I created a backup with the new option, the program took a few seconds longer than normal to bring up the operating system’s browsing screen. Subsequent backups, however, have been nearly instantaneous.

The option of excluding attachments, emails, and history was just added today.

Ok, not sure what is going on then. I’ve tried backing up three different companies I have on Manager and they have all reacted the same way.

Could it be something to do with the fact that I’m using a Mac? I will test it on a PC to see if the same thing happens and will report back.


Sadly, I can :frowning:.

With Internet Explorer (to simulate standalone running on Windows) it works

With FireFox (v79) it works (but the default is to Open the file)

With Chrome and MS Edge (the Chrome edition) it does not work.

If I use Curl it also works.
curl --ipv4 -v -o "Northwind_xxx.manager" -# -G "http://administrator:@localhost:8123/backup-download?FileID=Tm9ydGh3aW5k&Attachments=1&Emails=1&History=1&Name=Northwind_xxx"

@lubos according to rfc6266 it might be best to include both filename and filename* for the Content-Disposition: header.

I see that the old version uses exactly the same syntax so I guess it should work, but even curl seems to have problem detecting the filename from header. Just a thought . . .

1 Like

That explains it then, as I’m using Chrome!

Just checked it on a PC using Chrome instead of a Mac and the problem persists, so MarkLL must be right, it’s a browser issue. Can this be fixed?

No. All my tests were on a Mac.

Based on other comments, I will move this to bugs and change the title to reflect the actual problem. (Note, this is not the first time Chromium-based browsers have trouble where no others do.)

Ok, many thanks

Perhaps it would help if @lubos would test features on chrome since a lot of users use it, self included.

I know it’s not a be-all-and-end-all example, but even wiki says it’s the most popular browser:

Nice curl @MarkLL !

1 Like

I realized I don’t even have Chrome installed. Fixed in the latest version (20.8.49)

1 Like

Great, many thanks. Will check it out tomorrow.