Backup not importing to 16.12.47

Hi All

I recently updated my Manager Accounting from 16.10.91 to 16.12.47. It seems that during the upgrade process my existing database was not upgraded because it gave me a empty database.

I then tried importing my backup I made and got the following.

Internal Error

Sorry, something went wrong.

Please report this error to bugs@manager.io.

Also, please include the following information in your error report:

16.12.47 (Desktop)
/import-business
Manager.Persistence.FileCorruptedException: Exception of type ‘Manager.Persistence.FileCorruptedException’ was thrown.
at Manager.Persistence.PersistentDictionary…ctor (System.String path) [0x0010b] in <0726af92538d4173bb09267737e26347>:0
at ManagerServer.HttpHandlers.Businesses.ImportBusiness.ConvertFromLegacy (System.String source, System.Guid destination) [0x00000] in <1e528bed5d514f709e785b674dcfce3e>:0
at ManagerServer.HttpHandlers.Businesses.ImportBusiness.Post () [0x00179] in <1e528bed5d514f709e785b674dcfce3e>:0
at HttpFramework.HttpApplication.ProcessRequest (HttpFramework.HttpRequest request, HttpFramework.HttpResponse response) [0x00400] in :0
at ManagerServer.HttpApplication.ProcessRequest (HttpFramework.HttpRequest request, HttpFramework.HttpResponse response) [0x00564] in <1e528bed5d514f709e785b674dcfce3e>:0

I’m using ubuntu 16.04. Any help would be appreciated.

Below is a comment from another topic

Issue solved. Thank you for the SQLite tip, it set me on the right path. It turns out though, that I needed to install mono-complete package and run Manager through mono. I did the following things:
1.I followed the instructions in this thread for “Installing Prerequisite Software” : https://forum.manager.io/t/manager-wont-start-ubuntu-14-04/75281
2.I installed mono-complete package
3.I ran the application using mono with command: sudo mono /opt/manager-accounting/ManagerDesktop.exe

I am now able to run the appcication, and I am indeed able to import the business as well which solves the original problem as well. Thanks for the help.

No Luck.

Installed mono-complete. Ran the app through mono but still could not import the backup.

PS. The link in your response doesn’t work.

Try this

Thanks Brucanna,

I have installed the prerequite software. Still getting the same error.

I’m a bit worried about this is the error “Manager.Persistence.FileCorruptedException”

I don’t see that anywhere else in the forum.

Is it possible that the 14.04 repositories do not have the latest version of mono required for Manager.?.

@Grodd this will tell you your mono version mono --version

If it reports 3.x.x or thereabouts, I suggest that it would be worth installing the latest version (4.6.x.x from memory)
Te latest version can be had from here http://www.mono-project.com/download/

My mono version is up to date.

I too am having the same issue. Installed Manager on a laptop with Ubuntu 16.04 when my desktop died last month. I just got the desktop working again with fresh install of Ubuntu 16.04 and Manager Accounting. Basically mirrored the laptop. Since I was using Manager on the laptop over the last month I did a backup to a flash drive, and tried to import it to the newly installed Manager on the desktop. I received the same internal error message as Grodd.
BTW: had a heck of a time getting manager to launch on the desktop. I had to run a statement in terminal that I found on another forum. Manager now launches but that’s it.

Read this topic - a recent post there maybe your solution

Not running server edition of Manager, trying to run Desktop edition.

So what is your status? Your previous post implied you were now up and running. If you have a problem, describe it completely. Show screen shots as applicable.

Thank you for checking back. I cannot copy a backup from one computer to
another. Both are running Ubuntu 16. 04 and the latest version of Manager
as of right now 16.12.48.
I do a backup on my laptop to a usb flash drive, then move it to my desktop
. When I import an error appears as it does not recognize the file. I
noticed that the backed up file is zipped, so I extracted it to a folder
and tried to import that. Still no good. Why is manager zipping the backup?
Anything else I can try? Thank you

To have a zip backup file is to have an old backup. Currently (since Oct) all backup files are Manager Files - are you importing the correct file. Unless Ubuntu uses a different backup file system.

Actually, the files are still zipped, but they do not carry the .zip label because that was causing problems with some operating systems. I don’t know the details.

So if you are saying they’re in zip format, yes they are. But if they are labeled as zipped files, they are, as @Brucanna said, older versions.

The reason they are zipped is to accommodate attachments.

I have MA 16.12.48 installed on a laptop that is working fine. I have a
desktop with MA 16.12.50 (upgraded today and the same problem occurred with
16.12.48). I do not have any businesses set up on it. When I try to import
the business data that I copied from my laptop, I get the error message.
Then I tried to create a new business on the desktop computer that has a
fresh install of Manager 16.12.50 and nothing happens. The "add business"
button just jumps when I click it.

Perhaps the issue is with the re-built desktop computer rather then Manager, especially as you have Manager working ok under the same operating system on the laptop

Unfortunately the desktop only had a bad video card. In the beginning I was
using MA on that desktop with Ubuntu 14.04 LTS. All was well. Then the
desktop started acting up so I took out a laptop to use in the meantime
that has Ubuntu 16.04 on it and I installed MA to take the place of the
desktop. I imported a backup from the desktop and all is well with the
laptop.
Once I corrected the video issue with the desktop I installed Ubuntu 16.04
on it and a fresh install of MA to mirror what is on the laptop. I then did
a MA backup on the laptop with hopes of importing it to the MA on the
desktop. That’s when all hell broke loose and brought me to searching this
forum, Google, etc. Importing gives me an error message in a large yellow
box. So I gave up on importing and tried to simply create a new business.
Can’t even do that.
I can’t understand why I can’t even create a new business in MA on the
desktop. I have un-installed MA and re-installed it so may times it’s
ridiculous. And then each time there is a newer revision. It seems like
they keep patching it every day to make it work for some people and those
patches affect something else in a negative way.

Two things:

  1. Did you install the programme to the default location,and
  2. What files exist in the Application Data folder - to find this location go to About Manager