Manager ver 16.12.0 suddenly can't backup?

I’ve hit a bump in the road. This morning suddenly manager can’t backup. I select the backup button, I’m asked where to backup too, the select a destination window opens, allowing me to choose my backup file and on hitting save I keep getting an error message as follows:
"System. NotimplementedException:
The Required Feature is not implemented."
Manager has been working perfectly until now, I’ve made no changes and haven’t fiddled with anything.
I’m running manager on a netbook with Bodhi 3.2.0. This uses Ubuntu 14.04.
I don’t know if it’s relevant, but the same version of manager is running on Kubuntu 14.04 on a desktop and backs up perfectly.

Any pointers or help would be appreciated

Update your software to the latest version. That should fix it.

Hi @Tut, thank you for your quick reply. That was the first thing I tried and kept getting another error message with the new version 16.12.21. This informed me of a SQLite problem and a blank white screen.
I’ve just read @Lubos’s reply to another user with an ubuntu can’t start problem that manager is now using only 64Bit version of SQLite & my netbook is a 32Bit.
So it looks like I’m stuck with repairing my 16.12.0 version.(Hopefully)

If you search the forum, he has provided links to a pre-SQLite version of Manager to use until the problem is resolved. Apparently there are similar problems with other programs.

Thanks for the info, I’ll search and give the link a try.

@Tut, I tried the link that you suggested, it was for version 16.12.1 and gave me the same error message as 16.12.0 which was my original problem.
While the rest of the program appears to be working perfectly, I’m concerned with being unable to do backups. I’ve lost too much data over the years by being slack on backing up.
As my desktop version is performing in all area’s, I’m beginning to think that maybe it could be an operating system problem?
Any thoughts on this would be helpfull

If using the backup button is a bit touchy, then there is an alternate backup you could do by coping the data file folder.

If you go to About Manager, note down the Application Path and then navigate to that location.
Copy the folder to an external storage device and insert a date stamp into the backup folder name.
Do this as often as you would use the backup button until the issue is resolved.

Thanks @Brucanna. That’s the route I’ll take.

@vince, could you try the latest version (16.12.30)? It could make Manager to work on 32-bit Ubuntu again.

@vince, could you try the latest version (16.12.30)? It could make Manager to work on 32-bit Ubuntu again.


Visit Topic or reply to this email to respond.

To unsubscribe from these emails, click here.

@Lubos, Thanks for the reply. I downloaded and tried 16.12.30, but unfortunately it won’t open. Error message as follows:

"Error Information:
An exit code of 1 was returned from /opt/manager-accounting/manager-accounting.

Output Data:
There was no output

Error Logs:
There was no error message"

I’ve gone back to ver 16.12.21 for now and will just copy from my .local/manager file as a backup until a solution can be found.

BTW Lubos, thank you very much for what I consider to be the most user friendly accounting software available.Long may you continue!

@Lubos, sorry, wrong information given to you in my previous mail, I’ve gone back to version 16.12.0.
Version 16.12.21 was the start of my SQLite problems.