Backup Issue

facing issues with backup, please help
Sorry, something went wrong.
Please report this error to
If possible, please attach your Manager backup file so we can reproduce this problem internally.
Also, please include the following information in your error report:
16.3.52 (Desktop)
System.Collections.Generic.KeyNotFoundException: The given key was not present in the dictionary.
at Manager.Serialization.GetTypeByGuid(Guid guid)
at Manager.ApplicationData.Get(Guid entityId)
at ManagerServer.HttpHandlers.Businesses.Business.Start.Get()
at HttpFramework.HttpApplication.ProcessRequest(HttpRequest request)
at ManagerServer.HttpApplication.ProcessRequest(HttpRequest request)

Can you provide a description of actions leading up to this error message.
If you tried doing a backup again, do you still get the error message.

I was using Manger version 15.1.59, had backup using the backup button, I
installed the new manager version 17 and tried to import the backup to the
lastest version but when I tried to do so the backup does not run on the
latest version.

I think you need to send the backup file to @lubos to convert as there has been many changes to the data file structure since 15.1.59.

Anyhow, when you installed the new manager version didn’t it open the existing businesses ?

Even after installing the new version of manager it did not open the
existing business.

Ok, you need to send the backup file to @lubos for conversion.

My chance do you happen to save the download 15.1.59 before installing that version.

@lubos had sent you a mail with backup file please do convert the files and send it back