Arabic letter form problem

in pdf exporting and printing please do some effort to fix that problem

Do you have a problem not already described in this bug report topic: RTL support is a Must? If you do, please describe it in detail and post screen shots of any error messages. Your subject line does not furnish enough information to begin investigating any problem.

I have verified the problem and it is not an RTL issue. Arabic letters change form depending on the preceding letter or character. The letter forms are wrong.

Example:
Manager prints out the following as Arabic translation for Invoice Date:

تاﺮيخ الفاتوﺮﺔ

Correct letter forms:

تاريخ الفاتورة

The letters ر and ة should be in their disjoint form in that particular contex but instead we get and which are the connected forms.

Thank you, @Ealfardan. I have moved this to bugs and changed the subject to match the actual problem.

1 Like

@Maged, please explain your images. Do not expect others to see what you think are problems.

What I would like to make clear is that the support provided for the Arabic language in print and PDF is not sufficient
Please work quickly to solve the problem of printing in Arabic, as the file printed in Arabic is not identical to the original as shown in the pictures

Sorry but this issue of unicode ARABIC language in pdf,

So check your pdf setting and language setting in your system,

It use to happen with in another software, solve it by edite language setting

How is it not sufficient? Just saying something is wrong does not help resolve problems. As I said, explain your images.

Also, understand that Manager is not a what-you-see-is-what-you-get application like a word processor. Layout and even fonts are changed when creating PDFs. PDFs render the image differently than when printing through your operating system.

This post is already classified in bugs so it’s going to be solved for sure.

Meanwhile, you can use print button instead and it should print correctly.

1 Like

The PDF and email uses drivers built into manager. You cannot change this by tweaking your settings.

Instead you can use Print, which uses your own drivers.