Appimage does not work, crashes

Appimage, lastet version, crashed when open the business file.

/tmp/.mount_ManagecVuGxI/AppRun: Zeile 4: 7171 Speicherzugriffsfehler (Speicherabzug geschrieben) ${HERE}/opt/manager/ManagerDesktop

I try two different Versions but it does not work.

System:
manjaro-pc
OS: Manjaro 21.1.4 Pahvo
Kernel: x86_64 Linux 5.10.68-1-MANJARO
Shell: fish 3.3.1
Resolution: 3840x1080
DE: KDE 5.86.0 / Plasma 5.22.5
WM: KWin
Disk: 416G / 929G (48%)
CPU: Intel Core i5-7500 @ 4x 3.8GHz [41.0°C]
GPU: AMD Radeon ™ RX 480 Graphics (POLARIS10, DRM 3.40.0, 5.10.68-1-MANJARO, LLVM 12.0.1)

Sqlite: 3.36.0-1
webkit2gtk: 2.32.4-1

What versions have you tried?

Where did you download them from?

21.9.23 was the last working Version. I downloadet all Versions
from Releases · Manager-io/Manager.AppImage · GitHub
21.9.25
21.9.26
21.9.27
I use Manager most on Mondays and beginn with an update to the new version.
Last using 23.9. 2021 all was fine.

Today i had an big manjaro update, all works fine since 2018 not breaks or somethink, no entrys in the error logs, but this
Sep 27 11:52:45 manjaro-pc systemd-coredump[8433]: [🡕] Process 8340 (ManagerDesktop) of user 1000 dumped core.

Sounds like you O/S update is at fault

The download page on www.manager.io/downloads has following
image

but I don’t know enough about Linux distributions to say any more

i use manager accounting many years, and i have only used manjaro linux. But thank you

I think its somethink wrong if i open the database, sql file.
if i create a new file, it crashes also.

how can i debug the errors, to find out whats going wrong

@hanny so the app does not crash on startup. It crashes when you click on business name within Manager. Is that correct?

In that case, something would be wrong in relation to SQLite library. There are many Linux distributions. Typically, if AppImage works on Ubuntu and Fedora, I just assume it’s good enough since that should cover over 50% Linux desktop users.

Can you try if you can get free trial of Server edition going? If not, at least you should be able to see some error in console. That would help narrow down the issue.

Try tutorial here: Ubuntu | Manager

But only follow what’s in Downloading Manager Server section. Then just launch…

/usr/share/manager-server/ManagerServer

Once launched, navigate to http://localhost:8080 and see what happens.

Hello Lubos, thank you for replay,
yes it is correct, the app itself starts normaly, if i klick a imported business or create a new one, it crashes.

I will test and tell it later.

do you know how i can get more information from the terminal when the manager client crashed?
I open the appimage with ./
and i only get this feedback /tmp/.mount_ManagefHWk4v/AppRun: line 4: 14896 memory access error (memory dump written) ${HERE}/opt/manager/ManagerDesktop

Ok, back already.
I read the tutorial and remembered that I had seen on Github that there is also a server editon as appimage.
To test if there are problems with appimages, I tested those first. Downloaded and ran it, then ran it in the browser 127.0.0.1:8080. It works, my last backup applied and worked as well.
This does not solve the client problem but I could already enter some things and resave.
How long can I use the server version if the client is not working for a while?

systemctl status 
─app-\x2fhome\x2fmarika\x2fDownloads\x2fManagerServer\x2dx64.AppImage-e6e897a44b28434ea77fe93858cd28e5.scope 
           │   │ │ │ ├─11784 /usr/lib/appimagelauncher/binfmt-bypass /home/marika/Downloads/ManagerServer-x64.AppImage
           │   │ │ │ ├─11795 /bin/sh /tmp/.mount_Manage5KfP8t/AppRun
           │   │ │ │ ├─11799 /home/marika/Downloads/ManagerServer-x64.AppImage
           │   │ │ │ └─11803 /tmp/.mount_Manage5KfP8t/opt/manager/ManagerServer

The fix is…
sudo pacman -U /var/cache/pacman/pkg/gtk3-1:3.24.30-2-x86_64.pkg.tar.zst

Or whatever most recent version is in your cache. Don’t use gtk3 1:3.24.30+62+g8d04980f38-2

https://bugs.archlinux.org/task/72300?project=1&string=gtk3

This is problem on Arch & all Arch derived distros. Manjaro, EndeavourOS, …

1 Like

WOW, thats is it, thank for your help.

I’m running Manjaro (KDE) version 21.1 and there is no gtk3* but I do have:

gtk2-2.24.33-2-x86_64.pkg.tar.zst
gtkmm3-3.24.5-2-x86_64.pkg.tar.zst
gtk-sharp-3-2.99.3-3-x86_64.pkg.tar.zst

Manager doesn’t even start up in Manjaro and not wanting to move to a debian based OS. Any suggestions?

You need gtk3-1:3.24.30-2-x86_64.pkg.tar.zst this package, but do not upate it, go in the settings of pamac and set it on the ignore list after you install it