Linux Appimage is still not working

I don’t see why Mr. Tut would lock the issue, but it still remains and I suspect that I am not the only one. Just saying it should go to other topic does not help either. What other topic, Mr. Tut?

Anyway, Linux Appimage is not working for multiple distributions. By the way, the problem has been going for multiple releases. It starts normally but then if you click on the business, it crashes. I once managed to collect some information and it complains about “thread quashing”. By the way, the same error was reported in Github Linux Appimage repo without any replies by myself and someone else, too.

Please specify exactly your Linux server specifications and the OS installed. Also explain how you tried to install Manager and exactly where it gets stuck. Ideally with some log file.

Using Appimage for both Manjaro Linux and Fedora 35. Unfortunately, Appimage format does not leave any log files behind, I am aware of.

Please provide the hardware specs also, and the Manager install you are trying.

Typical AMD Ryzen 7 Lenovo Thinkpad laptop. Version 22.1.22 and earlier versions are not working. Used to work without problems a while back. After reinstalling the OS, I tried to reinstall

A quick search of the forum for “appimage” would have turned up:

The day I closed the topic you refer to, the one I’ve linked above was about three weeks old. Only one topic returned from the search would have been more recent, but that one was about scroll bars. The relevant topic was so easy to find I didn’t think I needed to furnish the link.

Looking at your profile, I see you joined the forum the same day you made your earlier post. Perhaps you did not read the FAQ, which contain useful ideas about how to get help.

@Gelderland on Fedora 35, you can run this command to fix the issue:

sudo dnf downgrade --releasever=34 gtk3

It is the system log files that will record the errors and would have helped recognise the error. For Fedora read Viewing logs in Fedora :: Fedora Docs on how to access the log files.

I made a search on “Linux” and I could not find anything relevant. I have been following such user groups since early 1990s. There are always Mr. Tuts. You could just have pointed me to the relevant topic, and I would have thanked you. I am not going to argue with you any further.

Actually I don’t regularly use Fedora, I use Manjaro, an Arch Linux derivative. I created a VM for Fedora just to see if it had same problem. It did.

I just looked but for Manjaro opening log files is quite similar to Fedora. See near end of discussion at Where are syslog logs stored? - #8 by pobrn - Support - Manjaro Linux Forum

There is little anyone can do to help without you sharing clear error information and only mentioning “thread quashing” which is probably even not an actual direct reference as a search on this absolutely returns nothing useful, so maybe the word thread is somewhere and quashing somewhere else but not together?

Did you try in the Fedora VPN to execute the command @lubos provided?

Also in the discussion thread that @Tut provided you find that downgrading gtk3 is the solution, @Lubos repeated the Fedora one and @Troni the Archlinux one which can be used in Manjaro.


I’ve been having the same issue for a while now, using Manjaro. Appimage opens but crashes as soon as I click on a business. Is a real PITA!

I found a workaround that doesn’t involve downgrading GTK3 as that leaves your system in a partial upgrade state. You will need to manually build GTK3 and remove tracker3 from it as that is what is causing the issue. One of the guys from the Manjaro team goes through the steps you need to follow:

Hope this helps you as well, If you manage to find a better fix, please let me know!!

1 Like

Thanks a lot for your help.

Did someone know when die Bug in GTK3 will be fixed, so we can update the package normaly?

@hanny, that is not a question for this forum.

what is the command to use to prevent updates to gtk3? I had it but can’t remember it. Haven’t been able to find it online either. I’m running Fedora 36 (Gnome) and successfully downgraded gtk3. Hopefully that doesn’t screw up my system.


I don’t use Fedora, but Manjaro which is arch-based. In any case, freezing gtk3 version is not a very feasible advise. Gtk3 is a fundamental package for GNOME based distributions and such would need to be updated quite often. It is amazing that Manager is released for 6 years old Linux releases. Maybe Mr Tutu could find a solution.

Murat H Eskiyerli

1 Like