Ability to rename existing field?

I’ve searched the forum and I didn’t see this addressed (maybe I just missed it).

I have a few clients who require a “Job #” to be on their invoice. Right now I have been putting that number in the Purchase Order Number field, but it would be nice to be able to create a new Invoice Template with that simple change. Then I could choose that template for those particular clients and keep the default invoice template for others. (Also, I can’t get rid of that “#” symbol in the field and it’s unnecessary with the word “Number” in the field).

I looked at the View Templates setting and even tried to create a new one, but I’m finding it very frustrating. I know a little HTML, but I don’t see an obvious way to just change a field name.

Otherwise, I’m very much liking Manager for my purposes, and congratulate you on a great program. Thanks!

The job # could be a Custom field on sales invoice form. Then you would need to inject content of custom field through View Templates.

It won’t be possible without HTML though. Just wait a bit for complete documentation on View Templates, then you can hire someone who knows HTML to modify your invoice template as required.

Thanks for the reply. Yes, I tried creating a Custom Field but I couldn’t get it to show up on the invoice template. I’ll await further documentation as suggested.

Nice job on the program, overall.

Hi @Don_G,

  1. Create you custome field in Sales Invoice. I name it as ‘job’.

  2. Go to Settings > View Template > Create ‘New View Template’.

  3. Name your template what ever you like. For this tutorial I name it as ‘Job#’

  4. Please copy highlight text to your templates code.

  5. Save (Create) your new template.

  6. Create or go to your exist Sales Invoices.

  7. View Template, select or use template you create just now then select it.

  8. Key In your Job #.

  9. Enjoy & good luck.

Thanks very much for the explanation. I’ll try it in the next day or so and let you know how it works!

1 Like

Thanks for the tutorial. After a little trial-and-error, I managed to get it squared away. In fact, I made another optional template with the Job # beneath the invoice number.

Now I’m trying to figure out how to eliminate the “#” sign before the invoice number, since it’s unnecessary with the word “number” right there. But I can live with that. :slight_smile:

Hi @Don_G,

To eliminate the “#” sign before the invoice number.

Edit your template again.


<div style="font-weight: bold">Job #</div>


<div style="font-weight: bold">Job</div>

Just replace Job # to anything you like or prefer.

Actually, I did eliminate the “#” in the custom template I created using “Job #”. But it’s the “#” in the Main template that I want to get rid of. The heading says “Invoice Number”, but then the field also has the “#”, which is unnecessary. I just don’t see a way to eliminate that.

For invoice numbering. Are you use any prefix format?
Example : IN15000

If yes.
You can replace “#” symbol with your own prefix.

Settings > Invoice Template > Invoice Number Prefix.

If you leave it as blank. “#” symbol will appear.

Only ‘Quote’ & ‘Purchase Order’ you can remove “#” symbol by edit your template.

I don’t know if somebody know how to eliminate “#” symbol with different ways.

@wazhanudin is correct. There is one trick though. If you replace # symbol with &nbsp; the symbol will disappear.

Keep in mind, sales invoice template will be soon obsolete as the look of documents will be entirely controlled by view templates in future. But for the time being, this workaround will work.

Ah, that’s great. Thank you for that trick!

But if it “will be soon obsolete”, I hope that means things will be even easier to customize rather than more difficult. I’ve been telling people how great this program is.

I cant find this option. Where is this option?

what you are not able to find?

you have revived a more than two years old topic. the program has changed a lot since.

I am unable to Find this option:
Settings > Invoice Template > Invoice Number Prefix.

that is because there is no invoice prefix option in the newer versions.
you can directly enter the prefix in the invoice number field.
but you will have to manually enter the invoice numbers with prefix every time if you set alphabets and symbols as a prefix.
if you just enter numbers as prefix, say 1700001 where 17 is the prefix to identify the financial number and 1 is the invoice number, Manager will automatically make the next invoice number as 1700002. Make sure you set enough zeros as per your requirements over a year.

Thank you for help