A Workaround for the Port 465 email issue

As port 465 is not supported by Manager and port 587 is not supported by my host I needed a workaround so that I could use gmail while avoiding the .gmail.com email address, as it is not MY domain name.
After a bit of searching I found that I could easily enough make the gmails from Manager appear as if they were coming from myusername.mydomain.com.

https://support.google.com/mail/answer/22370?hl=en

Hope this helps others to get thier brand back in their emails. :wink:

Don’t rely on this “feature” if you want to appear professional, because as far as I know gmail still broadcasts the fact the email is coming via them and some email clients (I believe outlook and thunderbird) show something to the recipient about that fact.

I still use this myself for my own domain, but it wasn’t until someone pointed it to me that I realised this happened.

For example, I just used my domain name to send an email and using another account to receive it I have checked the headers:

Return-Path: <d3****@****3.net>
Received: from mail-sor-f41.google.com (mail-sor-f41.google.com. [209.58.22.41])
        by mx.google.com with SMTPS id r9sor866065ilc.76.2020.08.11.22.30.24
        for <my**@**other-email.com>
        (Google Transport Security);
        Tue, 11 Aug 2020 22:30:24 -0700 (PDT)
Received-SPF: pass (google.com: domain of d3****@****3.net designates 209.58.22.41 as permitted sender) client-ip=209.85.220.41;
Authentication-Results: mx.google.com;
       dkim=pass header.i=@****3-net.20150623.gappssmtp.com header.s=20150623 header.b=Hnfh5vFQ;
       spf=pass (google.com: domain of d3****@****3.net designates 209.58.22.41 as permitted sender) smtp.mailfrom=d3****@****3.net
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed;

From a user comment on https://support.google.com/mail/thread/10572126 :

1 Like

Hi @VACUUMDOG, I’m with d3mad on this one I’m afraid.

Also you should look at PostMark (https://postmarkapp.com/) as they specialize in delivery of transactional email of which invoices, statements etc qualify. It will still deliver you emails as coming from yourname@yourdomain.com which is the professional way to appear. It also helps you to setup you domain so that SPF and DKIM are correct which helps to validate and verify your emails, leading to better deliverability.

Also, which hosting company are you with? I have a reseller account (so I can manage multiple domains) with an aussie hosting company which actually provide access to port 587!

I could add the email header to show the SPF and DKIM and verification and the other interesting points, but I think you get the drift.

So I would recommend trying to use your domain (without www or mail) as the hostname and port 587 and see if it works. If you use Ventra IP, then this may be of interest https://ventraip.com.au/faq/article/i-cannot-send-emails-why-am-i-receiving-an-outgoing-smtp-error/

I’m on Thunderbird and, unless you have selected View>Headers>All, there is no gmail reference and it shows as coming from my domain and it replies to my domain. You must untick alias in the gmail settings.
No matter, it works for me and might work for others without having to fork out any money.