Use of SSLwith Manager on ubuntu 16

I have install Manager server on VPS
configure port forwarding from 80 to 8080, so now i can open it with domain name on (mydomain.com) instead of mydoman.com:8080

Apache was also preinstalled installed on Ubuntu server.

now can i activate SSL for Manager, as it is using default port now (80).

do i have to activate SSL for apache2 only and it will activate on mydomain or i have to do something extra to use it with manager.

please understand that this is not a general forum. this forum is for discussion regarding the use of Manager accounting software only.

configuring SSL on your VPS has nothing to do with Manager software.

To add SSL, you will need to use some proxy HTTP server. The easiest one is Caddy where SSL certificate is obtained automatically from “Let’s encrypt”.

Here is install script which will install Manager Server 18.3.9 on port 8080 and Caddy on port 80 & 443.

#!/bin/bash

apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 3FA7E0328081BFF6A14DA29AA6A19B38D3D831EF
echo "deb http://download.mono-project.com/repo/debian wheezy main" | sudo tee /etc/apt/sources.list.d/mono-xamarin.list
apt-get update
apt-get install -y mono-runtime
apt-get install -y libmono-system-xaml4.0-cil
apt-get install -y mono-devel

mkdir /usr/share/manager-server
wget https://d2ap5zrlkavzl7.cloudfront.net/18.3.9/ManagerServer.tar.gz -P /usr/share/manager-server
tar -xzf /usr/share/manager-server/ManagerServer.tar.gz -C /usr/share/manager-server
                                
printf "[Unit]\nAfter=network.target\n\n[Service]\nLimitNOFILE=1048576\nExecStart=/usr/bin/mono /usr/share/manager-server/ManagerServer.exe\nRestart=on-failure\nStartLimitInterval=600\n\n[Install]\nWantedBy=multi-user.target" | sudo tee /etc/systemd/system/manager-server.service
systemctl enable manager-server
systemctl start manager-server

curl -fsSL https://getcaddy.com | bash
printf ":443 {\n  proxy / localhost:8080\n  tls { max_certs 100 }\n}\n" | sudo tee /usr/share/manager-server/caddy.conf
printf "[Unit]\nAfter=network.target\n\n[Service]\nLimitNOFILE=1048576\nExecStart=/usr/local/bin/caddy -agree=true -conf=/usr/share/manager-server/caddy.conf\nRestart=on-failure\nStartLimitInterval=600\n\n[Install]\nWantedBy=multi-user.target" | sudo tee /etc/systemd/system/caddy.service
systemctl enable caddy
systemctl start caddy
3 Likes

caddy now requires a license type to be entered on the command line (for the curl req).

curl https://getcaddy.com | bash -s personal

3 Likes

Hi Lubos,

Please advise me on how to renew the SSL on Ubuntu 16.04.6. I think last time I follow this step to activate the SSL in my VPS.

Thanks in advance
Khoiron

see this guide Ubuntu | Manager
For maintenance problems with Caddy you will get a better answer by posting on a Caddy forum

Thank you Patch.

I am done updateing the SSL