Upgrading Server Edition from Old Mono version

Oh, so the new version, deployment of ssl via caddy does not work.

What about doing a backup of database from the software, redeployu the server, and installing the new version, then import the DB backup.
will that work without any breakages?

HAve you deployed Manager with Docker. How?

I suggest it too. I’ve been on Docker for four years. Search for CRONET implementation of manager.io

Keep in mind to externalise the data folder!

interesting. though am not really a docker guru

I know it’s a lot heavier, but I have always just used a complete VM. I usually use the latest Ubuntu when spinning up a new machine, but the one manager resides on is an 18.04.

I would love to fully understand Docker, but the data connections and connectivity between docker components always confused me. I should give it another go one day, but it seemed it was like a whole lot more to configure, maintain and worry about. You not only needed to understand the various components that a complete VM took care for you, but you needed to understand those connections and docker configurations for them.

Granted I think docker is smaller, but I certainly don’t see it as easier :slight_smile: It’s like trying to use DoubleSpace or some compression utility where if you have the hard drive space, why would you bother?

Just my 2c worth :slight_smile:

Having said all that, I would like to learn more about it, perhaps I’ll reinvestigate. Do you know any good tutorials on the finer points of Docker configurations?

1 Like

Let’s get back to Manager, please. There are plenty of other places to discuss other software and systems.

The biggest question i have is.

SInce Caddy does not work. once i have deployed the new version of manager, how should i install the SSL onto it?

@Martin_Otieno it seems www.Manager.io uses www.letsencrypt.org see Guide system unreachable. Its likely preferable to use the same plus its free

You can view the certificate if you click the green padlock in the top of the browser and then select certificate
Certificate

thats is not what i meant.

I am unable to install letsencrypt. apache is not being found. cant use snap. etc.

what changes were made to this new version of manager?

I agree. I have been struggling with caddy since the new version of Manager and thought I did something wrong only to see mentioned here that it is outdated. So @lubos why did you update most of the installation instructions including where to get the latest server files and not either delete or at least adjust the caddy information so that SSL will work. I spent $300 in July for the server edition as we prefer to keep all our accounting data on our own server for security purposes. The original install including SSL worked effortlessly. It seem you are pushing you own cloud solution but the server solution is what attracted me to Manager. So please update the server installation instructions so it works as before. Thank you.

does anyone have idea to install SSL in this new version.
i am getting all manner of issues in that one component.

We use Certbot https://certbot.eff.org/ and Letsencrypt the link listed here will help you.

I tried it but keep getting the same error. “…\n\n404 Not
Found\n\n

Not Found

\n<p”…"

I checked the server and the DNS A/AAAA record(s) have the right IP address, so is not the issue. The issue is with the root path. Not sure what to use here as Manager is installed as an app

Your issue is not a Manager issue per se but computer / web thing. You will need to seek help outside the Manager Forum. Last thing what OS is the host on and check to establish if there is some other service in conflict with the Manager’s listening port. Check ports 80 8080 and 443 and start again. Good luck.

@Martin_Otieno @eko - as @compuit advised, this not a manager issue and looks like a webserver and SSL issue…you can replace caddy completely with apache2 tip:

  1. Install apache and then enable SSL module:
    sudo a2enmod ssl
  2. Use lets encrypt to issue a certificate
    sudo apt install python3-certbot-apache
    2.A - you need to setup DNS validation using your domain manager, example if my domain is example.com and i want to issue certificate for account.example.com then I would create the A record etc…
  3. Once the certificate is issued, amend the config file for apache to redirect ports to internal 8080 for manager etc…

Hope the brief steps will help you there.

1 Like

oh, so manager is not using apache but its using caddy.

so to get LE i need to replace caddy with apache. interesting. now i know why i have been getting issues

So Manager has its own webserver and running on port 8080 (default from setup). If you’re using Manager inside a protected network, then you can run Manager direct with “:8080” at the end of the local address without the need for caddy/apache.

If you’re running Manager access from outside secure network, then you go through the requirements to secure your connection using a webserver (in my case apache) and encryption with a certificate from letsencrypt. You then use Apache to redirect to the internal port of Manager. Any http or https request that comes in from the internet will then be redirected internally to Manager port 8080.

Note that caddy can still be used instead of apache but implement the solution that you can implement bearing in mind the maintenance required when there are future upgrades to Manager.

Thank you @PFIVE I got SSL working but it just shows the Apache page. I thus fail to implement:

When typing list 8080 or list IP:8080 it does not show manager but Apache homepage at best. Any further guidance appreciated s t the moment can only use on insecure http://ipaddress:8080 while in the past before updates when caddy worked I actually could use it in https://domain/subdomain (I do not even manage anymore to install it and get it to work in a subdomain such as https://domain/manager Wished I never upgraded, but at the same time also know that upgrading is important to keep going along with approaches and updates. However, this change away from Nano seems to cause quite some suffering without warning or resolution. An install should not be some cumbersome, it was working for a good time following Ubuntu instructions, including upgrade on the Manager.io site but somehow this discipline to present instructions that work now makes us depend on forum discussions and goodwill of people like @Tut or @PFIVE in this instance. I would advise to either remove the server instructions or update them so they work on a plain vanilla Ubuntu webserver. Thanks

Please note that it my view it has become a Manager issue as previous installs following Ubuntu | Manager including caddy did work effortlessly and was easy to update… until Manager changed, no longer is using mono and caddy install as prescribed disfunctional. I should have realized when following the “Upgrading Manager Server” instructions when the site failed to show again that there was a serious issue that does relate to Manager and the installation instructions that now fail to complete working with SSL on the internet.

@eko - totally agree with you there that the tutorial should be updated to reflect changes to caddy or the apache option…that is something for the developer to consider.

back to your issue, can you let me know what have you done when you say ’ I got SSL working but it just shows the Apache page’ - if you got apache running great you’re one step closer. Could you respond to the below list…The approach we will take first, get manager to run with apache without certificate, second, we apply the certificate from letsencrypt.

First checklist, note that when one answer is no, you need to fix before moving on;

  1. Is Manager running?
    systemctl status manager-server
  2. Can you access Manager direct from http:yourinternalip:8080?
  3. Apache - can you confirm that apache installed and confirm apache default page opening? just IP address without the 8080 port
  4. Setup apache redirection to internal port 8080;
    sudo a2enmod proxy
    sudo a2enmod proxy_http
    nano /etc/apache2/sites-available/000-default.conf

Replace the text with below - note to customise to your details where it says yourdomain.com

<VirtualHost *:80>
ServerName yourdomain.com
ServerAlias www.yourdomain.com
ErrorLog ${APACHE_LOG_DIR}/error.log
CustomLog ${APACHE_LOG_DIR}/access.log combined
ProxyRequests Off
<Proxy *>
Order deny,allow
Allow from all
</Proxy>
ProxyPass / http://localhost:8080/
ProxyPassReverse / http://localhost:8080/
<Location />
Order allow,deny
Allow from all
</Location>
</VirtualHost>

Save and restart apache;

sudo systemctl restart apache2.service

  1. Now try accessing http://managerinternalip (without the 8080 as in step #3 above) - if this was done correctly, apache will open manager instead of the default page.

End of part one…see how you go…and all the best.

2 Likes