Unresolved mailbox error

For whatever reason could not delete this post. Information at All you need to know about SMTP PORT 465 – Pepipost supports @lubos post that Port 587 is correct for SMTP and that implementation by hosting providers, especially with port 465 are outdated. (See below screenshot from link above).

are you sure your smtp server hostname is correct? it looks to me like a domain name rather than a smtp server name.
if your domain name provider and mail provider are different, you must update your mx records as per your mail provider in your domain dns settings first.
then make sure the smtp server name in Manager is exactly what your mail provider has recommended and not your domain provider. domain providers usually include a mail package with your domain service but that is not what we need.

Yes, both SMTP and IMAP use same mail.domainname This is common for many webhosting companies and in settings provided in CPANEL per domain. This used to work on and off. The problem is not with Manager, hence deleting the content of my posts and changing it. I may have to change mailservice provider that uses STARTTLS rather than the outdated SSL/TLS settings with SMTP port 465.

Because I have a different server provider for emails than the VPS that I use for Manager Server Ubuntu 20.04 the relay is not properly working as Manager will try to relay with STARTTLS on port 587 while the Email host uses SSL/TLS on that port so the handshake will fail. Only if Manager would allow to select (like some applications do) between STARTTLS and SSL/TLS this would make life easier for many of us facing this problem.