Trouble upgrading Manager to new version on ubuntu 14.04

I just tried to upgrade Manager from v16.11.70 to v18.5.41 on a Ubuntu 14.04 laptop and received an error, this is what I did:

sudo dpkg -i “Manager (3).deb”
Selecting previously unselected package manager-accounting.
(Reading database … 654261 files and directories currently installed.)
Preparing to unpack Manager (3).deb …
Unpacking manager-accounting (18.5.41) …
dpkg: dependency problems prevent configuration of manager-accounting:
manager-accounting depends on libwebkit2gtk-4.0-37; however:
Package libwebkit2gtk-4.0-37 is not installed.

dpkg: error processing package manager-accounting (–install):
dependency problems - leaving unconfigured
Processing triggers for desktop-file-utils (0.22-1ubuntu1.1) …
Processing triggers for mime-support (3.54ubuntu1.1) …
Processing triggers for gnome-menus (3.10.1-0ubuntu2) …
Processing triggers for bamfdaemon (0.5.1+14.04.20140409-0ubuntu1) …
Rebuilding /usr/share/applications/bamf-2.index…
Processing triggers for hicolor-icon-theme (0.13-1) …
Errors were encountered while processing:
manager-accounting

sudo apt-get update && sudo apt-get upgrade

You might want to run ‘apt-get -f install’ to correct these.
The following packages have unmet dependencies:
manager-accounting : Depends: libwebkit2gtk-4.0-37 but it is not installable
E: Unmet dependencies. Try using -f.

sudo apt-get -f install

The following packages will be REMOVED:
manager-accounting
0 to upgrade, 0 to newly install, 1 to remove and 0 not to upgrade.
1 not fully installed or removed.
Removing manager-accounting (18.5.41) …

Looks like this version libwebkit2gtk-4.0-37 is not available on ubuntu 14.04 therefore it can’t be installed, is this correct?

What Manager version can I roll back to get me going again?, as I won’t be upgrading ubuntu anytime soon.

The system requirements are stated clearly on the download page:

31%20PM

If you search the forum, there have been numerous discussions on this subject.

It looks like your installation of the new version of Manager was not successful. Isn’t your old version still in place? Or did you delete it? There is nowhere to download obsolete versions of Manager. (Yours is literally thousands of updates out of date.)

Thank you.
I didn’t delete the old version, after the new install failed the old version seemed to have been corrupted and came up with an error.

I found a previous version in my downloads and have reinstalled that.

https://packages.debian.org/sid/libwebkit2gtk-4.0-37