Tax Codes from Chart of Accounts not being applied

In Version 19.7.24, default tax codes that are associated with accounts in the Chart of Accounts are NOT “populating” the Tax Code field on Receipts and Payments. It always has done this before. It looks like a bug

@lubos i can confirm this is a bug.
19.7.24 Windows 10 x64

the problem is only with the accounts defined in COA which have a tax code set. while inventory items with a tax code defined does appear correctly.

i tried selecting the same account on a Sales Invoice and the tax code does appear automatically. so i guess the issue is with the Receipts & Payments although i have not checked with other tabs.

@lubos @tut If you agree that this is a “bug”, could it please be classified in the Forum as a “bug” so that it will eventually be fixed. Without the default tax codes “populating”, it is very easy to get to forget to enter the correct tax code for a transaction.

Unlike @sharpdrivetek, I cannot get this to work on sales invoices. I’ve tried payments, sales invoices, purchase invoices, debit notes…a tax code defined under Chart of Accounts doesn’t seem to be applied anywhere.

I’ve moved the topic to Bugs and changed the subject.

Just tried to do a BAS (GST) return to Australian Tax Office, normally use the GST Calculation Worksheet, this time it does not work. Upgraded to latest, still no work. Is this the same bug that is mentioned here?

PS: Have copied the code from Settings | Report Transformations | GST Calculation Worksheet in an older copy of Manager into the latest and the report works, there was nothing there in the latest version or the one before that. Something slipped out?

Your situation is completely unrelated. You need to read the Guides about localization.

@robyn see

Fixed in the latest version (19.7.30)

Thanks Lubos, I am guessing this was always included in the download of the software before, now we need to download it separately

@lubos Many thanks :grinning: