“System.IO.IOException: The process cannot access the file because it is being used by another process.”

I have tried the suggested, making sure that system is up to date, which it is

I am trying to change the file name, to todays date, for data continuity.

I get the above message. I restarted the computer and tried again and am still getting the same message.

Can anyone advise the issue? Last time this was bought up in forum was 18 months ago, hence why I’m asking again.

OKAY - fixed.
I tried adding a "new business’ and used the backup file.
Essentially the same file with the suffix of the backup dae and it worked.
So I will close this topic and hope it’s helpful to someone

Sorry, @Heather_Samsa, but nothing is fixed. You stepped around whatever your problem was. If something is wrong, it is still wrong. Please provide some further infomation:

  • What file name were you trying to change, and where?
  • How did you try to change that file name?
  • Exactly what did you do (what specific action) that triggered the exception message?
  • What edition (desktop, server, or cloud) are you using?
  • What operating system?
  • If server or cloud edition, what browser are you using?