Rounding in bank reconciliation

Please see screen shot.
I divide interest earned on a joint savings account 50/50 to allocate interest earned to specific individuals. You can see that the maths is incorrect, probably due to a rounding off failure.

This is causing problems with reconciling accounts.

The 1st shot shows a correct total for the transaction (£42.29). However when reconciling it shows the same transaction total incorrectly (£42.30) making the reconciliation impossible. See 2nd shot.

Screenshot_2018-08-23_20-05-25

Screenshot_2018-08-23_20-14-18

Thanks

The database is structured around line items. It seems that on the transaction entry form, the exact calculation (to three decimal places in this case) is performed. And no rounding is necessary. In the reconciliation process, both line items are rounded up, then added.

I agree this should not happen, and will put this into the bugs category. I have also changed the subject to be more specific.

Cheers, Tut

@muffin, you can get around the problem for now by manually dividing the transaction. Alternate allocating the extra half-penny between the two parties from period to period. That way, no rounding is involved.

Thanks.

This is not a bug. It’s how the program is currently designed.

When you are editing any transaction, the Amount shown on edit screen is not rounded but when posted to general ledger, it gets rounded (in this case) to 2 decimal places. This is necessary so your figures on reports don’t have more than 2 decimal places. You certainly don’t want your profit & loss statement to show 21.145 in some interest account.

This issue is not related to bank reconciliation. You can reproduce the same issue everywhere.

I want to improve edit screens so they round the figures in Amount field as you type so you can see the total for the transaction will be 42.30 if entered that way.

Just one thing I mention, using 0.5 qty is a clever trick but it won’t work on 42.29. It will work on 42.28 or 42.30.

1 Like

Mr. @lubos

I think if it is possible for you then try to add rounding up option in form default only with optipns
Round up to 2 decimals
Round up to whole number.

This will help a lot I guess.

Thank you.

  • The edit screen shows the un-rounded line items and sum of the un-rounded line items

  • The View screen, reports, and accounts elsewhere in Manager use rounded line items so result in the rounded total being used elsewhere in the program.

To facilitate data entry and correct for rounding errors, I would appreciate it if the “Rounded Total” was listed on the edit screen.

I’m not sure the best way of doing this. Perhaps the “Amount” column should be rounded to what will be used when the user click the update button. Alternatively the rounded total could be shown in addition to the full precision total.

Edit
Reading the full thread again, the solution has already been identified