Problem with batch update

I apologize if I seem to be hijacking the thread but i have 1/1/0001 on some dates once i do a batch upload on the cloud version.
Not sure if this is related but i have tried doing a batch update on those transactions and it seems the update does not work successfully


After the update.
If I attempt to edit the entry, the date field is found containing today’s date

Yes, you were hijacking the thread. Your post was moved to a new topic, since it had nothing to do with uncategorized transactions.

Your post is confusing. When you refer to “batch upload,” are you referring to a Batch Create or Batch Update?

You state that Batch Update does not work successfully, but your screen shots do not necessarily prove that. What date format do you have set?

Also, post a screen shot of the Edit screen of one of the transactions giving you trouble.

Batch create did not update the date data correctly and a batch update didn’t fix it either.

Actually on closer observation, all the transactions were either updated as MM/DD/YYYY instead of DD/MM/YYYY or came up as 1/1/0001

Apologies for cross posting. But I seem to be having this issue in the cloud version.
See below an excel table with some comparisons.
I also get some dates updated as 1/1/0001


@kendirangu, you have apologized for hijacking or cross-posting topics twice with the same issue. Rather than apologize, please just do not do it. This second post was moved to the same topic as your first one.

Also, please do not double-post on the same issue. That only scatters solutions so no one is helped.

Your screen shot of a spreadsheet is of no use in troubleshooting Manager.

For help, you need to show a screen shot of an Edit screen for one of the transactions that is giving you trouble and describe the circumstances involved.

I think i have articulated the issue and posted the manager screenshots.
My responses are based on searching threads with the keywords that seem to point to the issue.
The spreadsheet screenshot is to show the difference between intended date and the date appearing on manager.

below is a screenshot of the edit

You left out the most important part of the Edit screen. Show the entire screen.

I believe Manager internally uses the zero date as a flag for the system to insert today’s date.

So the issue is not why this happened but how did the user date get set to zero

Do you import bank statement?
I suspect there was a error in the format of the imported file.

You can correct the current entries by manually editing them.
You may be able to reduce future similar entries by looking closely at a raw view of the import file

It’s actually import of payments.

I am working with over 500 entries so manually editing is not really an option.
The main issue is that it changes the dates from dd/mm/yyyy to mm/dd/yyyy when i run the batch update.

1 Like

You must change the date format and the number format. After last update it accepts only mm/did/yyyy and numbers with dot for decimal.

1 Like

The transactions may be payments. But the question was whether you imported a bank statement. Or are you using Batch Create to enter these transactions? If you are using a bank statement import, what format?

Also, I suspect the screen shot you showed of the payment Edit screen is of the transaction after you already edited it. Is that correct?

Finally, you have not said what edition (desktop, server, cloud) and version you are using.

@tut after the last update Manager accepts only mm/did/yyyy and ##.00. It is not an issue since I changed the formats in my Excel transposition files and with history function you can easily revert the importation.

The real issue is that the formats of inport change from time to time without any notice and this is the at least the tenth time I had to debug my documents.

1 Like

I did not import a bank statement. I started out with batch create for payments and proceeded to update it severally. I have since figured it out as @Davide has suggested and amended my data accordingly.