Problem with Batch Create

When importing a batch of sales invoices from Sheet Excel with the same steps.
Data not imported, only displays the Sales Invoices form without new invoices.1

@Mmf, you have not illustrated a problem. You wrote that data was not imported. But your screen shots show the process has not been completed. (You have not clicked on Batch Create button.) What do you think is wrong?

Actually I click on Batch Create button but nothing happens.
I will try re-download and install the copy again.

Reinstalling is very unlikely to change anything. The program is functioning.

How many sales invoices are you trying to create at one time?

Have you followed all instructions in this Guide exactly: Use Batch Create and Batch Update functions | Manager?

84 sales invoices

Well, @Mmf, 84 is not so many. So I doubt there is any problem due to the size of the batch.

I cannot reproduce this problem, so it is not a bug. That suggests you have made some error in constructing the spreadsheet or pasting it into the Batch Create window. Here are some troubleshooting ideas:

  • Did you copy existing records using the Batch Update function to see the expected form for all columns in the spreadsheet?
  • Are you certain you entered UUIDs in every required cell rather than plain language?
  • Have you verified the UUIDs you did enter against a reference list to be sure you have used only correct UUIDs previously generated by the program for customers, etc?
  • Do your date formats match the date formats you see when viewing a Batch Update?
  • Are any of the sales invoices for multiple line items? If so, do all cells with multiple entries—such as Lines.Account—have the same number of entries?
  • Since many columns in the spreadsheet are often blank, are you sure you have properly aligned all entries under their correct headings? (Sometimes, it is difficult to tell unless you expand all the columns so none of the entries overlap empty cells.)

I am curious whether this is your first experience with Batch Create. Have you used the feature successfully before?

The problem has been resolved
I was working on version 20.9.62
Upon updating the version 20.10.60
I tried the import and the problem was really solved.

Your problem was most likely a date format issue. Recent program changes improved date handling. And my tests were conducted with version 20.10.60.

1 Like