DESKTOP EDITION CLOUD EDITION SERVER EDITION GUIDES FORUM

Problem testing server version


#1

I am using Ubuntu 14.04 LTS to test Manager Server. I have successfully tested the desktop version in both Ubuntu and Windows. To be able to recommend this software, I need to be able to successfully test a multi-user setup. I loaded the server version on my PC which runs Apahe web server on port 80, Webmin on port 10000, and some other services with no speed problems. I installed the server version of Manager and added “/usr/bin/mono /path/to/ManagerServer.exe -port 90 >>/dev/null 2>&1 &” to /etc/rc.local, then rebooted the pc (which is both my desktop and server.)

When my computer restarted, I accessed Manager by “http://localhost:90” which worked as quickly as opening manager on the desktop did. I created 2 users, and accessed manager using one of them. after successfully backing up the desktop version and restoring it to the server version I closed my web browser and accessed Manager from a windows PC using “http://192.168.3.125:90” where 192.168.3.125 is my server/pc IP address. I logged onto manager using the second user I created, then tested it. This seemed fine, giving acceptable speed for accessing the data remotely.

Next, I tested multi-user access. While user2 was still logged in, I attempted to login on the Ubuntu server/pc. The moment I logged in my server/pc slowed greatly, and the Windows pc Manger page stopped responding, then after waiting about 5 minutes began reporting connection errors and I/O errors. When I rebooted the system it began functioning as normal, but immediately slows down if 2 users are signed in.
I was using an older version of Manager and updated to 14.6.20 hoping that the newer version would help, but it didn’t make any difference in speed.

Do you have any recommendations which might make it possible for me to get a good test? Thanks!

By the way, as I have said before, Manager is great, and I’m impressed with the speedy updates.


#2

This seems like a problem in Mono framework, not in Manager.

Can you run mono --version from terminal and let me know what version you have installed?


#3

Result from ‘mono --version’

Mono JIT compiler version 3.2.8 (Debian 3.2.8+dfsg-4ubuntu1)
Copyright © 2002-2014 Novell, Inc, Xamarin Inc and Contributors. www.mono-project.com
TLS: __thread
SIGSEGV: altstack
Notifications: epoll
Architecture: amd64
Disabled: none
Misc: softdebug
LLVM: supported, not enabled.
GC: sgen

Hope this helps! Thanks, Roger


#4

Try to upgrade to the latest version of Mono which is 3.4.0. You might need to use following commands:

Download

http://download.mono-project.com/sources/mono/mono-3.4.0.tar.bz2

Extract tarballs

tar -xjvf mono-3.4.0.tar.bz2

Install it

cd mono-3.4.0
./configure --prefix=/usr/local
make
sudo make install

The issue is caused by embedded http server which is a component in Mono, that’s why I think upgrade could help because if it’s a bug, it might have been fixed.


#5

attempted to download and installed mono-3.4.0 failed with many error messages, tried to remove it and reload the version of mono supplied by Ubuntu. This also fails and I no longer have a workin version of mono on my system.


#6

What is the default file location for .manager files on Ubuntu Server? I would like to move them to the desktop version while I try to resolve the issues with mono.


#7

Have a look under

$HOME/.local/share/Manager

If you need to know where is your $HOME directory, type

echo $HOME

#8

Found the Manager data files, thanks!

Looks like I may have to do a full install of Linux to fix the problems with mono. I finally got Ubuntu-mono uninstalled, uninstalled dependent packages, reinstalled Ubuntu-mono, reinstalled mono-runtime, and now get a message


Missing method .ctor in assembly /root/managerdownload/ManagerServer.exe, type System.Runtime.CompilerServices.ExtensionAttribute
Can’t find custom attr constructor image: /root/managerdownload/ManagerServer.exe mtoken: 0x0a00000a

  • Assertion at class.c:5597, condition `!mono_loader_get_last_error ()’ not met

===> Stack trace messages follow, ending with: <===
.=================================================================
Got a SIGABRT while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries
used by your application.
.=================================================================
.
Aborted


After “Aborted” the command prompt returns. I still can’t run Manager.

Don’t know if you can help me since downloading and installing the latest version of mono broke my system’s mono. It’s completely messed it up.

By the way, I still like Manager, just don’t like Ubuntu’s method of embedding mono into the system. It makes it almost impossible to remove, and equally difficult to reinstall all the required components since it doesn’t list the missing or failing file(s) befor aborting.

Roger.


#9

Just updated mono to version 3.6.1 with no errors. Next I installed monodevelop which supplied missing packages necessary to run mono, also without errors. Mono is currently running on my system again, and I’m going to test ManagerServer.exe again. Hopefully without errors since


mono ManagerServer.exe -port 90


did not report errors on startup.

It took a while to find out how to resolve errors generated by my attempt to remove mono and reinstall it. I didn’t get it working by recompiling. That would have been nice, but I couldn’t get it to work.

If someone else needs to uninstall, reinstall or upgrade mono I’d be happy to help them along.

Thanks, Roger