DESKTOP EDITION CLOUD EDITION SERVER EDITION GUIDES FORUM

New Employee Form - How to clear data preset in the form


#1

Dear Sir,

Would like to seek advise, how can i clear the data preset in the Employee Tab / Form, when I click add new employee.


#2

What data are you referring to? Show a screen shot.


#3

when i click add new employee, it should be show me a blank page right? however it has fill out with all information that i had filled out before.


#4

what version of Manager are you using? what edition?
did you download Manager from the official website or any third-party website?

there is no provision in Manager to set default data for the Employees tab.
please provide a screenshot.


#5

i am using the cloud version


#6

@harward, are you clicking the button pointed out by the red arrow below?

11%20AM


#7

Same thing happening to me when I create a New Customer. The form is fill out with an existing customer.
I just put new data over the “defaults”.

This occurs only with Customers in one of my business files only.


#8

This must be related to Form Defaults which unfortunately don’t expose defaults for customers, employees, suppliers etc. If Form Defaults would expose these forms, you could fix this. So this is a bug.


#9

@lubos, your explanation makes sense in terms of behavior of the program. But how would default content for a customer/supplier/employee have ever gotten into the database?


#10

That is great mystery to me too. If this can be reproduced on new business somehow, I’d love to know how.


#11

I’m not 100% sure, but when Form Defaults were active and wanted to edit Sales Invoice defaults, we had to select a Customer to show all fields (and then clear the customer before save the form). This Customer info comes up when I create new record now.


#12

Are you sure you cleared that customer information and then updated the form default? If you did, the rest of the form disappeared from view, even though its content was there. If this is the problem, you should be able to fix it by revisiting the Form Defaults category in Settings and deleting the customer. (A recent program change eliminated the process you described.)


#13

Yes I know.

Revisiting Form Defaults-Sales Invoice category has only the info I wanted to, terms, delivery method etc. So, yes I’m sure that Customer Info was cleared from the form.

I have no problem with this behaviour of the program, just I mentioned for @lubos (maybe get any ideas).
Maybe this way the content for the customer gotten into database?


#14

yes, i am using the button to create new employee.

any idea how to fix it cos it is annoying with all unwanted data.

fyi, this behavior only appear in the employee tab.


#15

Please show some screenshots of the New Employee Tab, the Form Defaults and the Employee Form defaults?


#16

I dun find any default form for employee and here with the screenshots you request.


#17

Sorry, there isn’t a Form Default for the Employee - which is probably part of the problem.

I’ll leave this to Tut or Lobos as it certainly looks like a bug.

In my version, Desktop 18.4.45, the New Employee is completely blank.


#18

Check the latest version (18.4.50). You can clear employee defaults under Form Defaults in Settings tab.


#19

tks @lubos


#20

Jumping into this a bit late, but thought I’d also comment that I’ve had this “issue” since Form Defaults were first introduced, where my Customers tab allows me to set default values for all new customers.

I’m on 18.4.1 and I can already set defaults for a Customer because of this, and I could also do it on older versions. Have been using it as an “undocumented feature” as it seems no-one else could reproduce it back when I originally mentioned it here in the forums.

When I update to 18.4.50, I’m assuming I’ll be able to do it the standard way, i.e. from the Form Defaults screen.

Here’s a screenshot of what I currently see on 18.4.1:

I can edit that record and modify the values for those custom fields. Creating a new customer leads to it having those values pre-filled. Exactly how Form Defaults works for the other tabs, except I’m not supposed to have the feature yet.

Interestingly, the “Invoices” count says the number 1. Clicking on that leads to the Sales Invoices screen, but it’s filtered to show no results:

Clicking on another customer shows all of the invoices linked to that customer, as I would expect.

I’m going to update to the latest version now.

… and, I’m now on 18.5.5:

“Customers” now shows up in Form Defaults as expected, with my already pre-filled values from before I updated. The broken record no longer shows up in the Customers tab - it only shows my actual customers, no blank value any more. So it seems the problem is completely fixed.

@lubos - Perhaps I had already set default values for those custom fields, before you implemented Form Defaults functionality? And then because Customers wasn’t added to the list of supported tabs, it glitched out a bit and displayed it as a blank record instead, because it detected those default values as existing already?

In @harward’s case, he may have had defaults in the Employee tab for some custom fields prior to updating to the original Form Defaults release. However I don’t see any mention of a blank value appearing in his list view (which would certainly be noticable), otherwise he would’ve been capable of modifying the defaults like I could.

Or perhaps @ntrim is closer to the cause than any of my postulating above.

Either way, looks like the problem (or “unintended feature”) is resolved for all persons involved now, so my post here isn’t necessary, but thought it might be worth mentioning in case a similar issue crops up in the future - for a different tab.