Negative Average Cost Problem

There are some items in my inventory suddenly showing negative inventory cost and I don’t know where this negative numbers are coming from, can anybody help me why ? @lubos @tut

You need to post more information if you want someone to help.

SO far, all anyway can say is that, yes, you have some negative costs - whether this is a bug or an error in your transaction is impossible to determine without further details.

Perhaps you could post details of the transactions on one of the items with a negative cost so that the figures can be analysed

I think this is a bug, since yesterday I didn’t touch this inventory related things and suddenly changes now.

Probably, but if you post the information I asked for, it will help to analyse the bug and provide details to the developer so that the bug can be corrected as quickly as possible.

Before any correction can be made, the source of the bug must be identified correctly

Hey we are having same issue and also inventory transfers are not posting, like 500pcs of an item are still and the location on which goods receipt is made, all the transfers made after that, are not posted to the new location. transfer is made successfully but manager is showing 500pcs at the old location . its happening with most of the items and negative average cost problem is also suddenly there. and few invoices from 2018 suddenly became on top and are overpaid, despite we have lock date set to 12/2019

@fahadalarab can you please check whether the issue with inventory transfers is resolved now?

yes great. transfer issue is resolved

Can you check this guide? https://www.manager.io/guides/12951

It explains why those invoices are overpaid and how it should be resolved.

Hi Lubos, it still doesnt resolve my sudden negative average price on inventory. And I couldnt identified at all where this problems are coming from. Did you do any update that make this change happen ?

I couldnt post details of the transactions on one of the items since I think the problem because some credit note or debit note were missing.

I have this problem also - has just suddenly happened. Also sold items are not deducting from inventory.

We have this problem as well, average cost is not calculated correctly, if we have baught item X for 10 dollars and 20 dollars next time average cost is 2$ for example.
Is it a bug or is there any explanation ?

I have the same problem and besides my log entry is not displayed in the inventories, for example I have an article with a quantity of 3 in hand, I had loss and must remove 1… I make a log entry and remove 1… but the entry is not taken into account, it seems that all the entries of the journal are not taken into account in the inventory, before everything was fine. thanks for helping with this.

Just checked all delivery notes and goods receipts are appearing in suspense @lubos

I have no negative averages but for some reason ‘Inventory - cost’ for this month has gone from 869.87 down to 554.05 on P&L report (Cash Basis) and P&L net profit has gone from 193.98 to 510.81.
One of the issues is with freight-in not being included in average cost I think and also seems like GST is missing somewhere. If so then this might help explain Reports / Taxable Sales per Customer
My whole year profit has gone through the roof on the summary page.
Nothing in suspense.
Updated to 20.5.18 this morning from 20.2.6? I think it was.

Just noticed on General Ledger Transaction Report there is money in the Suspense account however it is not showing on the Summary. Other figures on the GL report also differ from the summary.

Please upgrade to the latest version (20.5.19) to see if any of these issues persist.

1 Like

Looks good so far…great service @lubos, thanks. (20.5.20)

1 Like