Missing Account selection possibility

Hi @lubos, when i copy a purchase order to a new purchase invoice i can’t select an account.

Screenshot%20of%20-%20New%20Purchase%20Invoice%20%E2%80%94%20Edit

I use the desktop version 18.8.13 on W10.

can u screenshot the same but with changing ur manager language.

I edited the original post

can u screen shot the whole screen . @Frankie

did u activated inventory items option from customization menu?

Inventory Items has nothing to do with the situation being illustrated.

it matters… just wana see whole screen of manager in full view.

Screenshot%20of%20-%20New%20Purchase%20Invoice%20%E2%80%94%20Edit

@Frankie read the guide first https://guides.manager.io/11111
u have to activate inventory items first. them either u purchase it from a supplier or u will create a production order that way products will be added to ur inventory. then u go sales invoice and create it n it will display products to choose from inventory list.
u can see a customize button below settings in left hand side of pic. click on inventory items and upte it.
ur problem will be solved

I can’t replicate this error. When I create a Purchase Order and then copy it to a Purchase Invoice the account selection field shows up

I’m testing this on W10 Desktop version 8.8.13

image
image

its because @Frankie didnt activated the inventory items . as in my opinion whereas @Joe91 u activated it.

Copying Purchase Orders to Purchase Invoices is not limited to Inventory Items.
The Purchase Order Guide’s opening states - A purchase order is sent to suppliers to order goods or services.
Therefore non-inventory Purchase Orders should be abled to be copied, therefore will elevate this to bug status.

I also cannot replicate this error running v18.8.13 on macOS v10.13.6. I suspect this is not a bug, but a corruption of @Frankie’s installation. Notice that the Account field is not the only thing missing in @Frankie’s screen shot. The Item field is missing, too:

12%20AM

I recommend reinstallation.

Don’t notice that actually, as in @Frankie screenshots they don’t have the Inventory Items tab activated therefore they shouldn’t be having the Item field displayed. Your screenshot has the Inventory Items tab activated therefore your judgement call isn’t comparing like with like.

That’s the bug, when cloning Purchase Orders to Purchase Invoices when the Inventory Items tab isn’t activated then the Account field is not displaying in the clone. As Purchase Orders can be used for services, (in accordance with the Guide) then those Purchase Orders should be able to be cloned regardless of the tabs activated.

I’ve removed and installed manager again, no result. I’ve found out that not all but just some of the Purchase Orders have this problem.

You can put Non-Inventory items into the Item field so Inventory tab is not a pre-requisite

Yes, but if they existed then the Item field would still be displayed, but it’s not being displayed.

If the Item field was a component of the Purchase Order, then @Frankie would have mentioned that both the Item field and the Account field wasn’t displaying in the cloned Purchase Invoice, but he hasn’t…

Do these that have worked and those that haven’t worked relate to any particular chart of accounts ?

My screen shot definitely does not have the Inventory Items tab activated. My screen shot does not even show the left navigation pane. As a matter of fact, my screen shot was taken from a test company that does not have Inventory Items enabled. It has purchasable non-inventory items.

This statement is incorrect. Here are screen shots from a brand new test company with no inventory or non-inventory items and the Inventory Items tab disabled. First a purchase order:

59%20AM

The purchase order is copied to a purchase invoice:

16%20AM

The Account field obviously appears.

I assume you mean copied, not cloned.

No, but i just found out what was wrong. It has to do with Non-inventory-items. I will explain it in my next message.