Linux instability

I am using Manager-linux-x64.AppImage on an Ubuntu laptop running the latest LTS release. Performance has been flawless for many years. But beginning about a month ago Manager has had stability issues. For example when I am entering a receipt, as I move through the fields weird things happen. Dropdowns lock up, lists don’t display, the whole screen jitters and then the screen contents disappear. It might reappear momentarily if the cursor gets to the right spot, but this is transitory. Manager is the only affected application.
I contacted Canonical, but they won’t look into it because Manager is not an
“approved” Ubuntu app. This leaves me hoping you can try to address this incompatibility with something in Ubuntu.
I downloaded the latest version of the app image from the Manager site today hoping a fix might have been made, but no luck.

1 Like

Is this something that can be reliably reproduced or completely random?


Is it the same problem as reported here?

It appears to be a consistent problem, but not reliably reproduced. I tried re-installing GTK3 on my Ubuntu OS, and while it’s a little less frequent the problem still is there.

I never had the problem with Ubuntu 20

Make sure that you lock the version of gtk3 see AppImage fails to load "stack smashing detected" - #15 by krystalsavage

This will ensure stability

Well, given that the update “libwebkit-gtk” was a safety related update, I’m not sure if it is a good idea downgrading gtk3 and then having safety issues instead.

I had Manager running fine on KUbuntu 18.04, KUbuntu 20.04, and initially tested OK in KUbuntu 22.04 as well.
No problem in almost 4 years until that particular update was applied.

I am running Ubuntu Budgie 22.10 with latest Manager-linux-x64.AppImage. Since 22.04 I have had all sorts of similar stability issues. Mostly by just entering fields, randomly, it would cause Manager to just crash. I have found a possible fix by going to ‘Applications’ in the Budgie Control Settings, scrolling to Manager, and disabling ‘Notifications’. So far, fingers crossed, I have not had a similar crash.

Glad I checked in before upgrading. Thanks everyone for posting this. I will setup a testing environment to see if I can replicate this issue as well.


I’m using Linux Mint LMDE Elsie Cinnamon version 5.4.12 and I’m trying to run Manager io on the system.

When I created a new Sales Quote and tried to put an amount in the ‘Unit Price’ box the program gets stuck. Only by closing it en restarting it I’m able to work with it again. Every time I want to change the amount in unit price in a sales quote it gets stuck (freeze) again.

The other actions I tried so far are working properly. (Making purchase invoice, making a payment etc.)

Alas, my crashes have returned.

@clive1973 unless you follow the instructions and have GTK3 installed until @Lubos manages to get on ttop of things I do not think that any Linux desktop version with GTK4+ will work as expected. Running a Linux server does not give any problem as it is not using a graphical environment to run and it is left to the browser of the networked user. I sympathise as I agree that this should be fixed because I strongly believe that any Linux for many is a a very good OS that supports wide ranges of hardware. Apple OSX is strong also because if its roots in Linux. So yes fingers crossed this get fixed sooner or later but in the meantime I strongly advise to have GTK3.

Thanks. I will install 20.04 in a VM box then and work it from there. :slight_smile:

Actually I am really confused now. I have installed 20.04 in a VM box and it crashes. I look under the bonnet and it is doing GTK4! But I never had any issues with Manager and my previous 20.04 (but I never bothered to know whether it was GTK3 or 4). Anyway, I am now working with manager-server as a workaround and ‘saving’ everytime I come out by backing up. Works fine.

The latest updates of version 20.04 TLS updated to GTK4 as you noticed. I thought that you would try the GTK3 addition to that install as in earlier posts. As soon as GTK3 also exists it should work fine.

I encountered a crash for the first time in Ubuntu-mate-20.04.1 desktop in a VM. Crash details indicate it’s the webkit2gtk-4.0 that caused the problem:

This is weird because gtk4.0 isn’t installed:

I run Pop!_OS 20.04 LTS and I’m experiencing the exact same issues with manager. I tried using the newer version as well and still experienced the same issue. I don’t think it’s a GTK4 related issue like most are alluding to because I’m still using GTK3.

I found the same problem suddenly crashes on Linux mint 21…How to solve it?