Issues with WebView2

I have installed WebView2 AND the latest desktop version of Manager ( 21.1.3 ) .
I use Google Chrome browser normally.
I do have Win10 Edge also on board my system:
Windows10 (kept up to date)

Question #1
How come I still get the prompt to install WebView2 ?

Question #2
How come the new version of manager doesn’t automatically default to using Edge like it’s supposed to (according to the blurb) ?

Yes I do just kill the prompt, and manager works as normal.
But it’s So annoying to have to do that each time manager starts up.

I don’t care which browser manager wants to default to, or use. I just want that pesky prompt msg gone. Yes I have cleared all cache data, restarted my computer after every update of windows AND of manager.

I’ve read all I can find about it in the forum but have yet to find answers.
Any suggestions greatly welcomed. Perhaps Lubos has the answer?

Regards Yer

When you install Microsoft Edge Webview2 Runtime, it should create registry entry at:


This is how Manager detects whether Microsoft Edge Webview2 Runtime is installed or not. If the registry entry above is not present, then Webview2 dialog will be shown.

Are you able to launch regedit app and see if the registry entry for Webview2 is present?

Yes I launched the regedit app.
It appears not to show a registry entry for WebView2. See scrncap below.

Yet I know I have Ms Edge installed. I use it for viewing pdf docs.

Perhaps I should have mentioned my computer is running win10, the 32bit version?
Where in regedit will I find the entry for Ms Edge ?
And can manager find it.

Regards Yer

I found the registry entry in a different place here…


So it looks like manager needs to look in that position as well, if one is using x86 windows.

Either that, or can you tell me how to create/edit the info into the WOW6432Node folder?

I double-checked Microsoft documentation on this and you are correct. Registry key on 32-bit Windows is stored at different location. So this is a bug at our end.

I have created a workaround for this problem.
It’s working now for me.

IF you are running Windows10 on a 32-bit machine.
It involves creating (by exporting) and prepping (by editing) a scriptfile.
This will enable you to add the missing info into the Windows10 register (32-bit machine).

WARNING: Always Backup your entire registry FIRST!

From the Start menu, type regedit.exe in the search box, and then press Enter.
If you are prompted for an administrator password, or for confirmation, type the password, or provide confirmation.

When your Registry Editor app is running…
Locate the 1st entry (Computer). It’s on the left of the Registry Editor.
Right-click the entry.
Click Export.
A dialog box pops up.
In the Export Registry File dialog box, select a location to save the backup copy, and then type a name (eg EntireRegistrybackup)
in the File name field.
Click Save.

BACKUP THE WOW6432Node key…
Double-click on the registry key HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node
Click Export.
In the Export Registry File dialog box, select a location to save the backup copy, and then type a name (eg WOWbackup)
in the File name field.
Click Save.

BACKUP THE EdgeUpdate key…
Double-click on the registry key HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\EdgeUpdate
Click Export.
In the Export Registry File dialog box, select a location to save the backup copy, and then type a name (eg EdgeUpdatebackup) for the backup file in the File name field.
Click Save.

Make a copy of the EdgeUpdatebackup file and name this copy “WorkingScript” (sans quotes)

Using Notepad, open and edit the “WorkingScript” file and…
Replace all instances of HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\EdgeUpdate with
Click Save.

Double-click on the “WorkingScript.reg” file.
This will place the info in the WOW6432Node.


Regards Yer

I’d suggest not to touch registry and just live with the dialog for a week or two until the issue is fixed at our end.

These keys are in Microsoft namespace and it could have undesirable consequences to make any changes there (most likely not but still).

@Yer, try the latest version (21.2.20). The issue should be no longer present.

Thank you Lubos, It appears to be working correctly. And I did check the reg changes I used as a temporary fix. They’re also gone now.

Thanks again for the brilliant software.


Yer Da

i have installed new later version of Manager today its give this option

when i installed and its give this error not open software .

please guidance required
early prompt action will be highly appreciated

Microsoft has changed something on WebView2 recently.

Here is the workaround until the issue is properly fixed.

  1. Download
  2. Right click on downloaded file and select Run as administrator option.


issue resolved
bundle of thanks for Quick Services.