Internal Error in Emails

System.Security.Authentication.AuthenticationException: The remote certificate is invalid according to the validation procedure: RemoteCertificateNameMismatch
at System.Net.Security.SslStream.SendAuthResetSignal(ProtocolToken message, ExceptionDispatchInfo exception)
at System.Net.Security.SslStream.CompleteHandshake(SslAuthenticationOptions sslAuthenticationOptions)
at System.Net.Security.SslStream.ForceAuthenticationAsync[TIOAdapter](TIOAdapter adapter, Boolean receiveFirst, Byte reAuthenticationData, Boolean isApm)
at System.Net.Security.SslStream.AuthenticateAsClient(SslClientAuthenticationOptions sslClientAuthenticationOptions)
at System.Net.Security.SslStream.AuthenticateAsClient(String targetHost, X509CertificateCollection clientCertificates, SslProtocols enabledSslProtocols, Boolean checkCertificateRevocation)
at System.Net.TlsStream.AuthenticateAsClient()
at System.Net.Mail.SmtpConnection.GetConnection(String host, Int32 port)
at System.Net.Mail.SmtpTransport.GetConnection(String host, Int32 port)
at System.Net.Mail.SmtpClient.GetConnection()
at System.Net.Mail.SmtpClient.Send(MailMessage message)
at ManagerServer.HttpHandlers.Businesses.Business.Settings.EmailSettings.EmailTest.Post() in D:\a\Manager\Manager\ManagerServer\HttpHandlers\Businesses\Business\Settings\EmailSettings\EmailTest.cs:line 88
at ManagerServer.Startup.<>c.<b__1_1>d.MoveNext() in D:\a\Manager\Manager\ManagerServer\Startup.cs:line 123
— End of stack trace from previous location —
at Microsoft.AspNetCore.Diagnostics.ExceptionHandlerMiddleware.g__Awaited|6_0(ExceptionHandlerMiddleware middleware, HttpContext context, Task task)

I did that, but it didn’t help me. I downloaded the latest desktop version of Manager yesterday before posting my comment above.
I must be missing something.

Which email provider are you using?

My host is from which I set up my own e-mail and website.

So what is the name of your SMTP server as is the domain name of your hosting supplier but not an SMTP address.
I set this up myself about a year ago, and have been using it for drawing my e-mail through Microsoft Outlook ever since.

There can not be a fullstop after the za

It should be
smtp server: 587

Then your login credentials, usually email address and password.

Sorry, a typo on my part above. There isn’t one.

I believe that every internal error is a bug regardless of whether there’s been a user fault, that’s why I am categorizing this in bugs.

1 Like

Looks like there is invalid SSL certificate installed on your mail server.

This is somewhat related to:

The next version will make the error prettier but there will be still error showing.