Test email settings fails with self-signed certificate

Hello,
Our email test fails with Manager version 21.3.40, it doesn’t like our self-signed certificate.
I use this email server daily, and when I set up Thunderbird to connect, I did have to accept the certificate. I was hoping that Manager would provide the same exception to allow it. But instead it just fails. Changing the certificate isn’t really an option at this point, as this email server is used by many different people daily, and if I changed it to a new self-signed cert, every person using this server would have to take an action to make email work again.

Is there a way to get Manager to accept this certificate?
Thank you for the awesome program!
Julie

OpenSuse Tumbleweed
Manager is AppImage 64-bit for Suse
Port is 587, same as Thunderbird’s settings

System.Security.Authentication.AuthenticationException: The remote certificate is invalid according to the validation procedure: RemoteCertificateNameMismatch, RemoteCertificateChainErrors
   at System.Net.Security.SslStream.SendAuthResetSignal(ProtocolToken message, ExceptionDispatchInfo exception)
   at System.Net.Security.SslStream.ForceAuthenticationAsync[TIOAdapter](TIOAdapter adapter, Boolean receiveFirst, Byte[] reAuthenticationData, Boolean isApm)
   at System.Net.Security.SslStream.ProcessAuthentication(Boolean isAsync, Boolean isApm, CancellationToken cancellationToken)
   at System.Net.Security.SslStream.AuthenticateAsClient(SslClientAuthenticationOptions sslClientAuthenticationOptions)
   at System.Net.Security.SslStream.AuthenticateAsClient(String targetHost, X509CertificateCollection clientCertificates, SslProtocols enabledSslProtocols, Boolean checkCertificateRevocation)
   at System.Net.TlsStream.AuthenticateAsClient()
   at System.Net.Mail.SmtpConnection.GetConnection(String host, Int32 port)
   at System.Net.Mail.SmtpTransport.GetConnection(String host, Int32 port)
   at System.Net.Mail.SmtpClient.GetConnection()
   at System.Net.Mail.SmtpClient.Send(MailMessage message)
   at ManagerServer.HttpHandlers.Businesses.Business.Settings.EmailSettings.EmailTest.Post() in C:\projects\manager\ManagerServer\HttpHandlers\Businesses\Business\Settings\EmailSettings\EmailTest.cs:line 86
   at ManagerServer.Startup.<>c.<b__1_1>d.MoveNext() in C:\projects\manager\ManagerServer\Startup.cs:line 89
--- End of stack trace from previous location ---
   at Microsoft.AspNetCore.Diagnostics.ExceptionHandlerMiddleware.g__Awaited|6_0(ExceptionHandlerMiddleware middleware, HttpContext context, Task task)

Currently, self-signed certificates are not supported.

Until this is implemented, I recommend to use 3rd-party mail server such as mailgun.com