Inter Account Transfers

Hi All

Im having trouble with my Inter Account transfers. Could anyone please help?

Seems to be same issue Apr 7, 2020 from Grace_Kemigisha.

Ive checked reinput the GBP currency - no magic fix for me.

This is Manager desktop version

I have two bank accounts - both are GBP - no foreign currency enabled in the account.

It shows Outflows and automatically fills Inflows with the same amount (in this case GBP295.16), yet the voucher shows the Inflows as “0”.

It also shows Exchange Rate on thhe voucher as GBP1.00 = GBP 0.00, GBP295.16 = GBP 0.00.

On the Summary tabs the bank accounts look like they are correct (ie the inter account transfers must be working correctly), yet if i look at the Bank Accounts they are clearly only updating on side (as the voucher shows).

Any ideas please?

What version number are you using?


In Settings tab, under Exchange Rates, do you have any entries? Based on what you have written, you should not.

Also, please post a screen shot of the Edit screen for the transfer.

Hi Tut

No theres nothing in FX tab (copy below).
Also attached the Edit screen for the Inter Account Transfer screen on 31 March 2020.
I get the same issue with all the Inter Account Trfrs, not just this one.

So the edit screen looks ok (shows outgoing and inflow). But the voucher always shows the Ex rate as 1 to zero and the inflow as zero.
The bank in the Summary screen shows correct inflow(see below), but the Bank account tab for Lloyds shows ‘zero’ inflow (also attached below)

Thanks for your help!

That is not what I asked for. I asked if there was anything under Exchange Rates.

Hi Tut

There is nothing in settings for Exchange Rates

Set the base currency
Base Currency

Then set at least one foreign currency
Foreign Currency

Then you will be able to select and set Exchange rates for then
Exchange rates

Hey Thanks for the help @Patch

I tried setting up another (GBP) currency ie GBP1 = GBP1 - to see if that would fix the problem.
Also updated to version 20.7.53 (from 20.7.51)

But the Inter Account Transfers still only show a one sided entry on the voucher with the “FX rates at GBP1=GBP0”. As below

First things first, @brisali1. An inter account transfer View screen shows exchange rate information at the bottom only when Manager believes the two accounts are denominated in different currencies. So, while both your accounts may be denominated in a currency named GBP, they are different currencies within Manager.

Second things second. You wrote:

Yet the screen shot does not show that. It shows:
Screen Shot 2020-06-27 at 6.31.58 AM
So it is not clear what you have shown—old status, new status, or something undefined. It is also not clear whether you originally had something, somewhere, set up as GBP=GBP. It sounds as though you might have.

To understand what is happening for you, let’s go back to the beginning. Is the screen shot in your first post the same transaction as the Edit screen for the inter account transfer shown in post #5? If not, please repost Edit and View screens of the same transaction that you claim is not functioning correctly.

Next, please explain exactly (step by step) how you got to the third and fourth screen shots in post #5. You seem to have at least one of your bank accounts assigned to its own control account. For the other, it is not clear. After explaining how you obtained these screen shots, repost them. But this time, include the bread crumbs (the blue hyperlinks) above both so we can see the paths you took to get there.

Finally, show us the Edit screens from the Bank Accounts tab for these two bank accounts. If those include account numbers, obscure the account numbers so you are not posting private information. Without information on how these bank accounts are set up, it is not possible to reproduce the conditions that are producing what you see.

Bank account Edit screens

Thanks for all the extra information. It allowed me to exactly model your situation. The good news is there does not seem to be any bug in Manager causing this. The bad news is I believe your experimentation may have corrupted your database. You wrote, “…so who knows what I actually did.” I can only model what you say you did.

I started by setting base currency to GBP. The business has no foreign currencies. I then created two bank accounts, Bank account #1 and Bank account #2. I assigned each to its own custom control account, Custom bank control account #1 and Custom bank control account #2, respectively. The only reason my custom control accounts have somewhat different names from the bank accounts they contain is so I can identify them for discussion purposes. I placed both control accounts into a group named Cash and bank accounts, just like you did. (You followed the correct procedure for making individual bank accounts appear on the Summary page and balance sheet in place of the default control account, Cash at bank. So that is not the source of your problem. The default control account does not appear on your balance sheet because there is nothing in it.)

I received 100 GBP into Bank account #1. Then I transferred 50 GBP to Bank account #2. The resulting inter account transfer Edit screen looks like this:

Screen Shot 2020-06-28 at 7.18.26 AM

and the View screen looks like this:

Notice there is no mention of exchange rates at the bottom. And outflows match inflows. The balance sheet on the Summary page shows the result. (Ignore the overall balance of the Assets group. There are other transactions in this test company):

Screen Shot 2020-06-28 at 7.22.35 AM

Drilling down on the control account balances produces exactly the list of transactions, at the correct amounts, you would expect.

So how should you recover? The first thing to try is to update your software. I did this with v20.7.47 and v20.7.53, bypassing v20.7.51 that you used. I do not believe this will make any difference, but it is conceivable there was a temporary bug. The program has moved forward extremely rapidly in the past several days.

Assuming that does not work, you could try the Batch Update function to look for relic database entries left over from your experimentation:

  • Be sure to make a backup of your business before you do anything else. And read and understand the Guide on batch operations: Use Batch Create and Batch Update functions | Manager.
  • Start with the Bank Accounts tab. Copy to clipboard and paste into a spreadsheet. Verify that the currency key UUIDs are identical for both bank accounts. If they are not, that is your problem. Make the UUID for Lloyd’s match the one for The Share Centre.

If that doesn’t work, you have three choices. (1) You could start over with a brand new business and recreate your records. You should be able to use the Batch Create function to help with this. It looks like only your receipts, payments, and inter account transfers include significant numbers of transactions. (2) Another option would be to ask the developer to examine your record for corruption. (I cannot guarantee that will work.) (3) Finally, since you implied you were experimenting with Manager, you might just set up a new business and begin fresh, without recreating anything.

Wow! Many thanks indeed @Tut for your very full, very swift, and very helpful response. Im so sorry to have caused you all the work, and truly appreciate all the thought and effort thats gone into your response.

Good news it seems not a system bug in Manager, bad news is it looks like Ive got some homework to do! Its getting a bit late tonight, so Ill set that for my homework tomorrow and let you know how I get on.

Once again, brilliant response @Tut much much appreciated! A quality Forum, with great support for us users: good to know you have our backs.

Thank you sir! :pray:

I couldnt contain my curiosity, so I checked out the banks using Batch Update… :face_with_monocle:

Taa -Daaaah! Success! :partying_face: :partying_face:

What I thought was going to be a chunk of work tomorrow turned out to be easy-peasy…thanks to @Tut !

The currency key UUID was absent in The Share Centre, (check out the empty cell below) so i copied the Lloyds UUID and uploaded.

Name Code Currency CreditLimit ControlAccount StartingBalance Inactive Key
LLoyds GBP 896606eb-54f6-4344-99fc-8b0ee0853340 d07053f2-6146-4dd0-b676-849fd002a36f 5276 FALSE 0f7a499b-4d8b-48e7-b1a6-a4ebdb7971ec
The Share Centre 42a5f8b4-2015-4ea7-81f1-777dad860c37 0 FALSE 6bda10ca-827b-4836-9cef-2022373f0217

All is now perfect:

  • The banks equal their control account balances
  • The Inflows and Outflows are all showing correctly
  • The Vouchers do NOT show an FX exchange rate and show equal balances on both sides.

All is good again in the Land of Smiles!!

Great job and thank you again, formidable customer service!! :pray: :pray: :pray:

I am glad it worked out. Two more comments:

  • I guessed wrong. I was fairly certain the issue would be differing UUIDs for your bank account currencies. But, because the Share Centre account was showing correctly and Lloyd’s incorrectly, I thought the Share Centre UUID would be the correct one. I was surprised to learn it was missing completely.
  • The forum is not, primarily, customer service. Unless the developer joins a topic himself, it’s mutual user support.

All the more impressive for being mutual users support…!

Very best