Installing on Fedora 37

I recently installed Fedora 37 and now I tried to install Manager and I got the following error,


I Installed the missing package and I still get the same error.

I ran into this same problem on Debian, but after installed the missing package it worked.

Hi @Ben7230,
Unfortunately, the only distro supported officially is Ubuntu.


However, other forum members have successfully ran Manager on other distros, so I will keep this post open so any Linux experts could help you out but then again, no guarantees.

Edit: Fedora is also supported up to version 33 as of the date of the screenshot.

Fedora is not the problem, in all Linux distributions it is with the GTK version. Install the gtk3 version recommended here AppImage fails to load "stack smashing detected" - #15 by krystalsavage

Will this works on openSUSE Tumbleweed as well? :thinking:

Right on the website its listed, Fedora 33 or newer.

I downgraded to gtk3 and locked the version as instructed, I still get the same error as above

Try first to make the gtk4 library work, see update instructions at Fedora 37: webkitgtk 2023-2dc87954d9 |

Ensure that you have some kind of backup. Also first run apt-update, apt-upgrade and apt-update again.

Out of interest, I tried this on Suse Tumbleweed in a vm
Used Yast to search for “libwebkit” and installed whatever it offered, following which Manager works just fine.

My foo with anything using the more modern versions of the Gnome DE (ie v3 onwards) on any base is not really up to snuff, but I would be willing to bet that the principle will still hold good.

1 Like

Awesome, good to know. Cheers mate! :coffee:

Running the command at this link does nothing, This is what I get;

Last metadata expiration check: 0:37:53 ago on vie 24 feb 2023 17:20:20 CST.
Dependencies resolved.
Nothing to do.

The funny thing is that on my laptop Manager works fine, Which also has Fedora 37 and is updated to the latest updates.

I noticed that the error relates to “eto.GtkSharp…”. An old post in the forum related to Fedora 2.7 RPM broken on Fedora 27 - webkitgtk no longer provided had a similar problem and seems to have been fixed by @eto 5 years ago… I am wondering if your laptop was a complete fresh install of Fedora 37 and the other computer with the error one that got updated over time.

It seems more an isolated problem with one of your systems and that is beyond Manager to resolve.

Its actually the other way around, my desktop has a fresh install of Fedora 37 a few weeks ago, were as my laptop was updated from Fedora 36.

Ok so I got past my first error by installing webkit2gtk4.0-2.38.5-1.fc37.x86_64

But now I have the problem of when I try to open a business it crashes.

And finally,

sudo dnf remove gtk3-3.24.36-1.fc37.i686

And then

sudo dnf downgrade --releasever=34 gtk3 -

And bingo, it now opens a business.

I will use it some and report back if I have any problems.

You have to supply screenshots otherwise difficult to help.

If I try that, I get this:

sudo dnf remove gtk3-3.24.41-1.fc39.x86_64
Probleem: De bewerking zou resulteren in het verwijderen van de volgende beveiligde pakketten: gnome-shell

Which means something like: error, would result in removal of following secured packages: gnome-shell…
So I can’t use your solution. (I’m on Fedora KDE)

EDIT: apparently I still had some gnome-remnants, so I removed those, but the error just changed to … : plasma-desktop.

This is weird! When you chose KDE you actually would not use Gnome!

To be sure GNome is gone use command:

sudo gnome out

and KDE present use command:

sudo kde in

No no, I indeed think Gnome is now completely gone, I used sudo dnf swap fedora-release-identity-workstation fedora-release-identity-kde and sudo dnf remove gnome-*.
Now the error is about plasma:

 Probleem: De bewerking zou resulteren in het verwijderen van de volgende beveiligde pakketten: plasma-desktop

So it would result in removing plasma-desktop. That is KDE, no?

Please provide some more details. As you indicate using Desktop version did you download it from Download | ?