Installing Desktop on MX Linux (Debian)

Does anyone know how to install Manager Desktop on MX Linux which is based on Debian? I found another thread where someone suggested to just download and install the deb file, but where do I find that?


The only Linux download available is the AppImage.

Doh! I was running it on Manjaro (Arch) for a while and installed it from the repo. Then I went back to Windows 10 for a while, and recently decided to give MX Linux a try. I wasn’t familiar with the AppImage format, so I had to google that after your reply. Easier than I expected! I guess I was over complicating it. :slight_smile: Thanks Tut!

1 Like

@maudman I’m using MXLinux 19 currently to host Manager Server Edition. If you have any issues or bugs regarding Manager on top of MX Linux. Tag me in. I will test it as well.

Glad you found a way to make it executable ( chmod +x) or via gui right click on appimage within properties and permission tab.

Hi, Tut.

Hope you are well.
My Linux crashed and I retrieve my backup of the Desktop and I did install with the .deb file last year. How do I now install that AppImage file because to just change the (chmod u+x) or the right click and change permission doesn’t install it, you can move it around on your system, is that the only way it will be working without installing?

I Google to find how to install it, but this is what I get: you can run the AppImage without installing it, but you must install it if you want it to be completely integrated with your desktop environment.


You are asking the wrong person, @BillionDollars. I am not a Linux user. Someone else will need to help.

Thanks, Tut. Will the developer know, or someone else you know?

Just download the appimage, make it executable, and then import your business and you will be up and running.

The Manager appimage doesn’t run as an installer type package unlike some appimages, but just runs the Manager programme

Hi, xero50.

Thank you, I did it.
Now how do I change the icon to the M of Manager, any idea?


You could possibly harvest a png image from the Manager website or forum and use that.
How you associate that with the link to the appimage executable will depend upon which desktop environment you are using.

The AppImage is in fact an iso image. So if you copy the file by adding the suffix «.iso», you can then click on the iso file to extract the icon. You can then create a launcher on the desktop using the original «.AppImage» and the extracted icon.

I got it worked in Linux Mint 19.3, but I moved to Kubundu 20.4 LTS and now the AppImage doesn’t open even with all the help from all the forums of Ubuntu.

Hope here is someone that can advice why it doesn’t execute now.


Some more detail about what is an isn’t happening would be helpful…

That said, assuming that you are running Kubuntu 20.04 on x86 hardware, it might be worth just making sure that the Universe and Multiverse repo’s are enabled.

Have you made the AppImage executable? Right-click on the file and then see Properties and Permissions.
Then click on the AppImage file to see if it opens.

Hi, Coco.

I tried to do that, but it couldn’t be done like that so I search Google and find how to do it from the terminal but it still didn’t open because there was a lib package not install and after I installed that I’m back in Manager.

I found 2 threads, this one and this package libwebkit2gtk-4.0-37 was mentioned to be installed, in the forum that also show the same issue with the libwebkit package and that helped to solve the installation in Kubuntu.