Linux Ubuntu Installation

I have a new desktop with Linux Ubuntu 22.04.01 as the operating software. I have downloaded the Linux version of Manager, copied the AppImage to the desktop and also enabled it to execute the program as a file. However, when I try to open this file, nothing happens. I am new to Linux so is there anything else that needs to be done before Manager will open on my desktop? Thanks

Did you use chmod a+x Manager.AppImage to make it executable?
Did you use ./Manager.AppImage ? or how did you try to execute it?

I checked the “Allow executing file as program” box under Properties / Permissions.

to be able to open the appimage from desktop you will have to:

  1. Right click on your desktop
  2. Click on Settings
  3. Scroll down to the bottom and look for Action to do when launching a program from the desktop
  4. Click the drop down menu on the right of it and set it to Launch the file

Now launching the appimage from the desktop by clicking on it should work.

I seem to be missing the option “Action to do when launching a program from the desktop”. Is there a way to enable this setting?

Did you right click on your desktop screen on Manager.Appimage?

Alternatively if still not showing do .desktop files not launching from desktop in Ubuntu 20.04 LTS - Ask Ubuntu

May I remind you that this is not an Ubuntu Linux forum but a Manager forum. You should search the web, read the Ubuntu manuals etc if stuck.

No, you don’t have to do nothing else. It should work fine by giving it permission to be executed as program. I would delete the AppImage and redownload it again from Manager’s official download page and try again.

Apologies, i didnt intend for it to be linux forum related. I will get some further help as none of the above worked for me. Appreciate your assistance.

I did download again but still had same issue. I’ll have to get some tech support as none of these suggestions have worked unfortunately.

As a test, it might be worth trying to launch it from within Ubuntu’s file-manager.
That way, you are more likely to see a report about any complaint or problem.
You may for example find that you need to install libwebkit2gtk and that will be displayed when launching from within the file-manager if it is required to be installed.
Similarly, from within the terminal, move into the directory containing the manager appimage file and type

./Manager-linux-x64.AppImage

then hit enter and see what happens