Import business error

Just downloaded version 19.12.10 and trying to create new business by importing a backup from version 15.1.74 but got this error:
Screen Shot 2019-12-24 at 17.40.40


Your old version was so far behind the program cannot convert the data file to the new format. @lubos will have to convert it for you. Send the file to

You are many thousands of versions behind, as Manager advances rapidly. Good practice is to update at least monthly.

when restore backup data 2.3GB backup file (import business) in server edition when uploading 90% automatically close ManagerServer.exe and coming error “This site can’t be reached refused to connect.”

Yes I received similar issue when attempting to restore / import using the Manager’s Import business option in the server version. That function does not seem to handle the larger backup files well. Not sure where the size cutoff may lie. Just tested with a 619Mb company file and worked / restored / imported fine. By the way this test was pulling a backup file from offsite … so a full company data restore from another location to the Manager server in the data centre.

Historically our company data files over 1Gb had trouble so our backups run outside the Manager realm. I will run up one that is 2Gb and lets see what the outcome is…

Yeah it is a case of the System’s Browser timing out as the backup takes too long a time to copy to the data file location on the Manager Server. The error that comes up in our case is a proxy error due to timing out.
Apache (Ubuntu)
The proxy server received an invalid response from an upstream server.
The proxy server could not handle the request
Reason: Error reading from remote server

We could prove the theory by placing backup file on the local LAN at data centre or setting browser / server not to time out so quickly and keep alive… but I have no time for that at the moment.

It was a known limitation for the cloud version.
The same limitation probably applies to the server version.

ok, tks


do you have any update for above Concern

My datafile is small enough to backup and restore without issue so I have not tried to debug this further.

I believe the backup an restore operation are actually just a file copy and rename.

So you maybe able to achieve your desired outcome by

  1. Locate your Manager data folder (in Manager click on the “Preferences” tab at the top of the page, copy the location shown for “Application Data file”, paste it into your operating system’s file bowser or navigate there manually).

  2. Create a new (empty) business with the desired name.

  3. Quit Manager (server and / or desktop)

  4. In your operating system, move the newly created data file out, copy in your backup file, and rename it to he same as the moved file (a hexadecimal UUID)

  5. Restart Manager & see it my guess worked (it did for me)