Import bank statement MT-940 file

Does somebody know how to import an MT-940 bank statement file in Manager?

Have a look at

Okay, now i don’t get it anymore. The bank transfer should be an MT940 file, but when i download it, is is a textfile, .txt.

That is the reason that Manager is not accepting it. So it must be an .sta file and not .txt?

Manager can import many formats but the format Manager expects is determined by the file extension. If you are importing a file in STA format, it must have .sta extension. Can you rename the file so it ends .sta?

Hello Lubos,

if i do that, i get an internal error.

System.IO.InvalidDataException: Can not find trailer!
   at Raptorious.SharpMt940Lib.Mt940Parser.CreateStringTransactions(IMt940Format format, String data)
   at Raptorious.SharpMt940Lib.Mt940Parser.ParseData(IMt940Format format, String data)
   at ManagerServer.HttpHandlers.Businesses.Business.BankAccounts.ImportBankStatements.ImportBankStatementForm.ParseBankStatementLines(String fileName, Byte[] buffer)
   at ManagerServer.HttpHandlers.Businesses.Business.BankAccounts.ImportBankStatements.ImportBankStatementForm.Post()
   at HttpFramework.HttpApplication.ProcessRequest(HttpRequest request)
   at ManagerServer.HttpApplication.ProcessRequest(HttpRequest request)

Can you send the file you are trying to import to ?

Hello Lubos, did send the file. Did you check it?

What version are you using? I tried to import your STA file into the latest version and it worked fine.

Manager 14.9.26, and working from USB flashdrive.

Download the latest version then…

Is the latest version also available in Dutch language?

Yes it is.

I have now version Manager 16.11.35
Now manager is working with money amount . instead of ,
Not possible anymore to import files because all the files work with , instead of .

Go to Preferences next to About Manager, click on the blue number and then select your local number format.

Not sure if reviving this topic is the right way to go about this question, but I have a MT-940 file from a bank with the extension


So, I cannot import it in Manager as supported formats are:

*.qif, *.ofx, *.qfx, *.qbo, *.sta, *.swi, *.iif, *.csv

What is the best way to proceed here. Should I try and save the file to one of the supported formats?

The list of extensions seems to be outdated. You can rename .300 extension to .940 which will be then interpreted by Manager as MT-940 file.

Awesome. Thanks @lubos