Error Message on Server 18.5

Internal Error
18.5.2 (Server)
ProtoBuf.ProtoException: Invalid wire-type; this usually means you have over-written a file without truncating or setting the length; see
  at ProtoBuf.ProtoReader.SkipField () [0x001b8] in <720f553b571b4fe7b0ce50f7171ec1a8>:0 
  at ProtoBuf.ProtoReader.SkipField () [0x00174] in <720f553b571b4fe7b0ce50f7171ec1a8>:0 
  at ProtoBuf.BclHelpers.ReadDecimal (ProtoBuf.ProtoReader reader) [0x00042] in <720f553b571b4fe7b0ce50f7171ec1a8>:0 
  at (wrapper dynamic-method) Manager.Model.Customer:proto_70 (object,ProtoBuf.ProtoReader)
  at ProtoBuf.Serializers.CompiledSerializer.ProtoBuf.Serializers.IProtoSerializer.Read (System.Object value, ProtoBuf.ProtoReader source) [0x00000] in <720f553b571b4fe7b0ce50f7171ec1a8>:0 
  at ProtoBuf.Meta.RuntimeTypeModel.Deserialize (System.Int32 key, System.Object value, ProtoBuf.ProtoReader source) [0x00045] in <720f553b571b4fe7b0ce50f7171ec1a8>:0 
  at ProtoBuf.Meta.TypeModel.DeserializeCore (ProtoBuf.ProtoReader reader, System.Type type, System.Object value, System.Boolean noAutoCreate) [0x00015] in <720f553b571b4fe7b0ce50f7171ec1a8>:0 
  at ProtoBuf.Meta.TypeModel.Deserialize (System.IO.Stream source, System.Object value, System.Type type, ProtoBuf.SerializationContext context) [0x00022] in <720f553b571b4fe7b0ce50f7171ec1a8>:0 
  at ProtoBuf.Meta.TypeModel.Deserialize (System.IO.Stream source, System.Object value, System.Type type) [0x00000] in <720f553b571b4fe7b0ce50f7171ec1a8>:0 
  at ProtoBuf.Serializer+NonGeneric.Deserialize (System.Type type, System.IO.Stream source) [0x00005] in <720f553b571b4fe7b0ce50f7171ec1a8>:0 
  at Manager.Serialization.Deserialize (System.Guid contentType, System.Byte[] content) [0x00046] in :0 
  at Manager.ApplicationData.Get (System.Guid entityId) [0x000e7] in :0 
  at ManagerServer.HttpHandlers.Businesses.Business.Start.Get () [0x00011] in <712d8c024e134a82bfb282a62f230ec2>:0 
  at HttpFramework.HttpApplication.ProcessRequest (HttpFramework.HttpRequest request, HttpFramework.HttpResponse response) [0x0040d] in :0 
  at ManagerServer.HttpApplication.ProcessRequest (HttpFramework.HttpRequest request, HttpFramework.HttpResponse response) [0x004e8] in <712d8c024e134a82bfb282a62f230ec2>:0

can you provide details as to when this error occurred? what OS?
can you check whether you get the same error after importing a backup file?

I don’t think this is a bug. Looks like database corruption. But if you want me to check for sure, send 0780ec6d2d744ed0b89d356de2d8a66b.manager from your application data folder to my email address

I have a demo server installed locally on ubuntu and I have decided to go vps. So I had a Debian set for me with Manager Server 18.5.2. I did import my backed up company successfully and when I try to enter it , I get that error

Did you try to open the business data file directly? Or did you first launch Manager, then select the business on the Businesses page? The second approach is how things are supposed to work.

I added a business by importing my existing one

Does your business open correctly if you download the desktop edition and import the business to it?

I get another error

Then when refresh I get the usual one!

So, if you can launch Manager in both server and desktop editions, but trying to open your business causes the error, it has to be a file corruption as @lubos said. Send him the file he requested.

I did a lot of investigation since I also have this error on one of my databases.
I was not able to open this one due to the Invalid wire type exception.

Even my daily backups reported the same issue, so I was not likely a database corruption.

I have tried a lot of older version of manager, and learned that I can open the database up to version 18.4.38, since 18.4.39 the wire type exception pops up.

Something in this specific database causes an error, which might be related to the new functionality which was introduced in 18.4.39 (Starting Balance in Setting)

Can you try to open this file in the Desktop edition 18.4.38?


1 Like

Manager Will not open files that are opened by a newer version. It Will pop-up a warning and says install latest version.

I am quite sure this database was not opened before with a newer version, if it is the Same problem that I see that is not possible

I understand your concern,so my advice Will be can you make a copy of the file and try to open that with version 18.4.38

Where can I find that specific verion?

@Paulvm, your post with an outside link was deleted. The forum will not support or condone downloading from unofficial sources. The proper course of action for @ypettemerides is to send the accounting file to @lubos, the developer, as requested. Anything else is a dangerous workaround with the potential for creating even bigger problems.

@ypettemerides, please do as you were requested and abandon unproductive searches for answers that do no solve your problem.

Okay, no problem.

The link is the official download link from the manager website, but I changed the version number in the download link. So I think you can call this an official download link, not an outside link.

I only try to gather more information, to prove that this a BUG.
I already send my database to @lubos proactively last Friday.

I’m still quite confident that @ypettemerides will be able to access his data with the version, but I do understand your point of view…

I am sorry, but it is not. It may be something you downloaded from the site, but it is not the official link. And, as you admitted, you changed something. There are risks the forum will just not support.

This was a bug after all. Not a database corruption. Fixed in the latest version (18.5.6).

So, shall I upgrade the Server and everything is ok???

Yes. Upgrading will resolve the issue.