Error importing statement

Hi - I am receiving an error message when trying to import bank transactions. The initial error was ‘internal error 18.10.36 - you are running an outdated version…’ - so I have downloaded the latest version and now receive ‘internal error 19.2.78’. Hope someone can set me straight! Many thanks…

Post a screen shot of the error message.

Internal Error

19.2.78 (Cloud)

/import-bank-statement-form?FileID=c9a5d0a3-71b9-4836-b2f7-8a2daab4d83c&Referrer=59b2c847-2a5b-4699-ab3e-831c07726ed9

System.InvalidOperationException: Nullable object must have a value.
at System.Nullable`1.get_Value()
at ManagerServer.HttpHandlers.Businesses.Business.BankAccounts.ImportBankStatementForm.ParseBankStatementLines(String fileName, Byte buffer)
at ManagerServer.HttpHandlers.Businesses.Business.BankAccounts.ImportBankStatementForm.Post()
at ManagerServer.HttpApplication.ProcessRequest(HttpRequest request, HttpResponse response)

Here you go:

Screen Shot 2019-04-10 at 8.40.57 am

1 Like

I get the same error and checked the csv files I uploaded and were working perfectly in the past. Did something change? Error_upload_csv

1 Like

I tried to import another format then csv and the 940 worked without getting the error message

Hi
I have been trying to try to import bank statement, also getting the same error message.

What is the workaround for this?

Pls advice. Tq

There is no workaround except manual entry of bank transactions until the bug can be identified and fixed.

Oh dear, this is really disappointing Tut. Importing bulk transactions is one of the key features of this programme for me - and I have until April 20th to submit my quarterly business activity statement. Do you think it is likely there will be a fix in the next few days or do I really need to start ploughing through manual entry now?

@MartinL, I have no connection with development of the software at all, so I have no idea how long a fix might take.

All I can suggest is—if your bank offers statement exports in more than one format—that you try all of them. I am only speculating, but if this was a universal problem, I think there would be more complaints here on the forum. CSV is generally the most problem-prone format, based on historical comments. So I would try all the others first. That should go fairly quickly. If not successful, you have 10 days to enter the transactions manually.

Yes it would probably be easier to do manual than import all transactions as I first take them into a csv file to separate personal from business (CC transactions). It’s a great shame as it was working fine up til now. Do I need to do something to get it onto the developers bug-fix list?

OK I have a work-around for anyone having this problem with a csv file. I converted it to a .qif file using this online converter and the import worked as normal: https://csvconverter.biz
It’s a few extra steps which is frustrating, but way better than manually entering transactions…

1 Like

This is already on the bugs list.

Cool - fingers crossed for the next quarter then!

Hi, I’m getting the same error message for csv file upload. It worked perfectly last week (I last uploaded 4 April 2019). So something must have happened from a coding/bug perspective from Thursday to today. Thanks!

Hope @lubos can check this out. I for one need to do tax submission by 15th April. Thanks!

Sorry about this. I was adding support for more CSV columns and broke something. Fixed in the latest version (19.2.81)

3 Likes

Good to know - thanks Lubos. Was looking a bit troubled for a while!

Can any body lead me to more information about this? Thanks! :slight_smile:

I asked about that privately when the post was first made. I was told the emphasis in that comment was on “adding support for more columns,” not yet actually adding the ability to decipher more columns. The idea was to eventually be able to parse more columns, then offer a service of diagnosing troubles if users encounter them. But the ability is not there yet.

Understand! Thanks!