DESKTOP EDITION CLOUD EDITION SERVER EDITION GUIDES FORUM

Encountering issues with customer batch update


#1

I am not able to batch update data info of my customers for unknown reason. There supposed to be one confirmation box showing changes made where you can verify changes and then select green box saying “batch update” to save your changes.

In order to be sure about this particular issue I created a demo business and tried to update the customer data. Surprisingly, it is working fine.


#2

Can you describe in more detail exactly what happens in the business that doesn’t work? If possible illustrate with screenshots. After all, a screenshot of a business that has no problem isn’t useful for troubleshooting. Thanks.


#3

Attached screenshot of customer batch update from my original business.

As per instruction, I updated data in excel and then copied and pasted into the text field. Then I clicked “next” button which brings up the same page as above instead of taking me to the next step where I expect to see changes made with a green box saying 'batch date" which basically updates my data.


#4

I think it would help if you post the screen shot with the data or some of it displayed - as it stands any comment would just be a guess as to what is not working

You don’t seem to have any customers


#5

Attached screenshot. I have about 1900 clients


Suspense Batch Operation
#6

Here’s what I get with Windows Desktop version 18.10.35


Click on Batch Update


Copy to Excel, change and copy back

Click Next

Click Batch Update


#7

hi @Joe91 screenshot no. 4 is missing in my case. After i paste updated data from spreadsheet in screenshot no.3 it reverts back to screenshot no.1 without changing data


#8

Looks like there is a problem with the data pasting back - does it show up in the text box before you click on Next?

What version are you using?
Maybe there is a problem with the amount of data being copied from the Copy & Paste


#9

Yes pasted data shows up in the text field before clicking “next”

18.10.36

I am not sure about this. But I definitely know there something wrong with my business file. As I don’t face this trouble when I create a new business


#10

You could try copy back the data for 1 customer only to test whether it’s a problem with the volume or with the process


#11

I tried for 1 customer and it didn’t work. So it has nothing to with the volume - as I usually do this and so far never encountered a problem. The problem is in the process itself


#12

Are you sure you are copying the column headings, both from the program to the spreadsheet and from the spreadsheet back to the program? And are you certain you have not modified any of the hexadecimal keys?

I don’t personally use batch updates for customers. But I once had a problem doing a batch update on a transactions list. In my case, I was able to go through the process as expected, but the updates simply did not affect the transactions list. After 4 or 5 attempts, things finally worked. I never understood what caused the problem.


#13

Good question. But I am sure that column headings are in order while copied and pasted. Furthermore, hexadecimal keys were never changed.

I attempted a zillion times now. But it does not work anyway. I am sure something is wrong within the process


#14

Did you change just one customer while leaving the entire rest of the list intact? Or did you delete all the customers you were not changing and only paste back the modified one? If you have not tried that, give it a try.

Also, I think I recall from other posts of yours that you use either the server or cloud edition. If so, @Joe91’s concern about the volume of data may be more relevant. With 1900 rows in the table, the quality and speed of your internet connection could be to blame. The largest batch update I’ve ever done was about 550 rows. That was the one I described above that gave me a problem. I can’t remember for certain, but as I think back, I may have resorted to truncating the pasted list or divided it into segments. And my internet connection is very high speed.


#15

Hi Tut. I tried both ways. Specifically, I tried to change one customer’s info and left others as default and copied pasted to text field. I also tried to change data of one customer and deleted all other customers and then copied and pasted them. None of them works.

Since it is not working for one customer can we consider this a problem within the process? Or you still believe it should be something related to the volume?


#16

I agree there seems to be something wrong with the process after you’ve taken all these troubleshooting steps. The fact that it works for other businesses, however, suggests it is probably not a program bug, but something about your data file for this one business.

I will invite @lubos into this thread. He may ask for your file.


#17

dear @lubos sorry to bother. But I need to batch update customer’s info ASAP. Could you pls tell me what is going wrong in my file? Its kind of urgent. Thanks


#18

@lubos Would appreciate a reply pls


#19

@lubos I never heard from you! I am facing serious problems as I need to update contact details of almost 2000 customers ASAP. I am also uncertain about the cause of problem and still trying to find a solution in almost a month now. Please guide. I desperately need help


#20

Try the latest version (18.11.15) as batch create / update screens have been rewritten. If the issue persists, best if you send your backup file and spreadsheet you are trying to paste to support@manager.io. There is nothing forum can do if nobody else can reproduce the issue.