Email Settings

Hello I am evaluating the server version (V22.7.5) I am trying to setup email settings in order to send invoices by email directly to the client but there are only 2 ports available in the drop down menu, of which none of them are usable with my hosting server.

is there a work around this?

Thank you

First, you are hundreds of versions out of date. Update your software to obtain help on the forum.

Second, those are the only two port options.

thank you for the reply, I have tried updating following the information at: Ubuntu | Manager

but the version is still the same.

Server installation and administration are managed by the business installing them.

If your business does not the requisite IT support to do this, then you should reconsider whether the Server version is the appropriate version to use

The Cloud version may be much more suitable

ensure that the WGET link is as follows;

that is the link used but version is still the same

use Sudo Reboot to reboot the server.

already did… :frowning:

but even of I do manage to update the fact that only two ports are available is not really going to solve my problem!

@Nicholas_Hadjipavlou, who is your email host, and what port do you want to use?

mocha host and ports that we can use are as follows:

Secure SSL/TLS Settings (Recommended)

Password: Use the email account’s password.
Incoming Server:
  • IMAP Port: 993

  • POP3 Port: 995|
    |Outgoing Server:|

  • SMTP Port: 465|
    |IMAP, POP3, and SMTP require authentication.|

Non-SSL Settings (NOT Recommended)

Password: Use the email account’s password.
Incoming Server:
  • IMAP Port: 143

  • POP3 Port: 110|
    |Outgoing Server:|

  • SMTP Port: 2525|
    |IMAP, POP3, and SMTP require authentication.|

@Lubos can you please look into this because you seem to have changed some code of the SMTP sending client used in more recent Manager versions. As I upgrade whenever a new release comes out (currently on v23.7.13.877) I can not really stipulate when this happened I agree that a perfectly working email SMTP server setting recently only keeps mentioning “Mailbox unavailable. The server response was: SMTP AUTH is required for message submission on port 587.” When switching to port 25 then the test email shows in green (email sent) but it actually never got sent and when trying to email an invoice it would still show an SMTP authorization error. Whatever settings I use, it no longer works.

This is for emails with several email hosting providers to name Hostinger and A2Hosting that confirmed they did not change anything and that it is a problem with the “Sending client” not with their Service. Could you please check if something changed in the Manager SMTP sending client code? Thx

That’s not going to work with Manager’s inbuilt email

Please show the whole set of codes you use to update Manager. Use the </> button to past the code.

Have you tried to use SMTP port 587? Because nowadays that’s the recommended port.

Yes, until recently it worked fine on all businesses with different email providers but now with whatever setting it does no longer. Hence my alert to @Lubos on this. The email providers even gave me their own server rather than domain deviants but to no avail, so deductive reasoning puts it in the corner of some code change of the SMTP module in Manager, maybe even through an auto-update of the framework elements. I sincerely hope this gets looked into and resolved soon.