Dutch VAT return: BTW-privégebruik

Hi @Hennie, the btw-privégebruik is added to Manager but on the Concept-btw-aangifte it doesn’t show. Am i doing something wrong or is this a flaw of Manager.

I looks like it is a bug in the concept-btw aangifte.
I will make some tests and when it is indeed a bug, I will report it to the developer.

@lubos
What Frankie reported that the VAT code for BTW-privegebruik doesn’t appear on the concept btw-aangifte is correct. In my test-company I created a journal entry for private usage of a company-car using the VAT-code for private usage and indeed it doesn’t appear on the concept-aangifte at line 1d!
See the attachments. As I already wrote, to me it appears to be a bug. Please put it on the bugs-list.
Kind regards,
Hennie
concept-btw-aangifte|533x500

I have separated the above thread as a new topic and placed it into the bugs category.

This is now fixed. Use Check for updates button when viewing the report as per this guide: https://www.manager.io/guides/23352

Thanks Lubos, but is it not fixed correctly. My tax-liability is now shown as a deductable.
Please fix this.
See attachments
Kind regards

Hennie

For someone with knowledge of the Dutch tax system do these calculation have any obvious errors

{% assign 1a_grondslag = netSales[BTW_21] | default: 0 | floor %}
{% assign 1a_omzetbelasting = taxOnSales[BTW_21] | default: 0 | floor %}
{% assign 1b_grondslag = netSales[BTW_6] | plus: netSales[BTW_9] | floor %}
{% assign 1b_omzetbelasting = taxOnSales[BTW_6] | plus: taxOnSales[BTW_9] | floor %}
{% assign 1d_omzetbelasting = taxOnSalesMinusTaxOnPurchases[BTW_privegebruik] | default: 0 | times: -1 | floor %}
{% assign 1e_grondslag = netSales[BTW_0_verlegd] | plus: netSales[BTW_0_vrijgesteld] | plus: netSales[BTW_21_verlegd] | plus: netSales[BTW_6_verlegd] | plus: netSales[BTW_9_verlegd] | floor %}

If this (the calculations form the current Concept BTW Aangifte) look reasonable. Then printing out your input data to the Concept BTW Aangifte is probably going to help debugging as it would enable reproducing the error (ie it shows the interface between your Manager business & the localisation, separates out purchases & sales, and shows what other tax code results are in case there is an interaction).

To print out the input data go to

  • Settings -> Report Transformation -> Click on Edit button for “Concept BTW Aangifte”

  • Scroll down to the “Layout”

  • Insert four new rows, see here

  • Copy / insert the following code (which will print out the total for all of the tax codes used in your business).

  • Click on the update button at the bottom of the transformation edit screen

  • View the “Concept BTW Aangifte” which should now also show the input data.

Note when you update the Concept BTW Aangifte, these debug changes will be overwritten by the new official version.

I think the issue was that 1d_omzetbelasting variable was multiplied by 1.

The latest version of the report doesn’t do it anymore so that should fix the issue.

1 Like

On behalf of the Dutch users thanks for the fix.

1 Like