DMG installation on Mac OS Mojave

Just upgraded to v18.10.96.
Downloaded DMG, opened and drag app to Applications folder.
Manager appears in Applications folder as a shortcut, rather than a programme, so whenever I open Manager from the Application folder it opens the DMG then runs Manager.
The DMG folder remains on the desktop.
How do I install this version as an app rather than a shortcut?
Didn’t happen previously.

I believe that instead of dragging the Manager icon to your Applications folder, you dragged the opened disk image itself. If I do that, I get the behavior you described. Move the alias from Applications to the Trash. Open the disk image and drag only the Manager icon to Applications.

If you get an error message, don’t panic. The operating system may have reassigned any Dock alias to the disk image.You may have to close out the program, delete any previously existing alias in the Dock, relaunch, and then choose the option to Keep in Dock (if that’s what you want to do). No matter what, none of your data will be affected, because it is elsewhere, in your application data folder.

Let us know if you have trouble.

Thanks Tut
I did indeed drag the Manager App icon to the Applications folder, and not the dmg. file.
In other words I downloaded the latest version of the app, opened the disc image, and then dragged the Manager App from there to the Applications folder.
In the Applications folder I see ‘Manager App’ with a shortcut arrow in the bottom LH corner of the icon.
So don’t understand why its a shortcut, rather than the app itself.
I have already tried trashing that shortcut and then moving the app from the window that opens when I open the dmg. folder, but I still get a shortcut in Applications, rather than the app itself.
Any thoughts?

@plasmaman, I have personally downloaded and updated twice since you posted your original message, one to 18.10.96 and again to 18.11.1. In neither case, if I install correctly, can I reproduce what you see. (And I am running macOS v10.14 Mojave.)

This is not a Manager issue. This is something you are doing (or have done) with your Mac. One thing that caught my eye was your statement about seeing “Manager App” with what you called a “shortcut” arrow in your Applications folder. (In macOS terminology, these are aliases, not shortcuts.) There is nothing in the entire Manager disc image named Manager App. The application itself is named Manager. When you drag it into the Applications folder, it looks like this:


And the software bundle that contains it (which is what you are actually dragging to the Applications folder) is also named just plain Manager. If you create an alias of the bundle, it will be named Manager alias and look like this:


I suggest downloading again and installing the latest version. No need to uninstall anything first.

When I open the .dmg I see a window with the Manager icon and underneath “”. Nothing else.
If I drag the app icon from that window to Applications folder, it appears in Applications as 'Manager" with the alias (shortcut) arrow in bottom left corner.
If I open the alias from the Applications folder the programme runs, but opens the .dmg folder on the desktop.
That happens with either 18.10.96 and 18.11.3.
So tried again.
Deleted Manager fro Applications folder, downloaded 18.11.3 and opened .dmg.
This time instead of dragging ‘’ to Applications I right clicked and copied ‘’ to desktop, then dragged the copied ‘’ to Applications.
Now Manager appears in Applications as an app rather than an alias, and when selected to run does not open the .dmg.
Strange…anyway thanks for pointing out that there is another update.
BTW is there a way of configuring an alert to updates being available?

OK. I had not expected that your preferences would be set to show extensions. Most Mac users are quick to opt out of that. I didn’t realize it because you didn’t include the dot after the program’s name.

Glad you got things sorted out.

There is no automatic alert for updates because they happen so often. Significant ones are announced on the Releases page.

Thanks Tut
But that doesn’t explain why dragging from the .dmg folder to Applications folder creates an alias, whereas copying and pasting from .dmg folder to desktop then moving that to Applications folder moves the app rather than creating an alias?
Any thoughts?

Just saw further update 18.11.5.
So tried a slightly different method.
Opened .dmg.
Dragged Manager .app from .dmg to desktop, then dragged from desktop to Applications folder.
Works fine!

No, it doesn’t. It explains why I gave you the answer I did. I was working with information that was not precise or complete.

Next update, try dragging directly to the Applications folder. I suggested this earlier to overcome a potentially corrupted download. But you have not mentioned whether you did it. No other Mac user has ever reported this, so I really think it was a random download problem or human error.

I have experienced exactly the same problem. Double clicking Manager.dmg in the Downloads folder brings up the volume /Manager which contains Dragging to the Applications folder creates an alias in that folder to the app in the volume. The application may be invoked from that alias, but then if the volume is deleted there is no app! I found it necessary to explicitly copy the file to the Applications folder.

Well, @mcgood, you are the second person in history to report this problem. My explanation to you is no different than the one I gave to @plasmaman. This has to be something you’ve done on your Mac. I think I can fairly say I have probably updated Manager on a Mac more than any other user in my role as forum moderator. I’ve already done it dozens of times on Mojave alone. The closest I can get to replicating this problem is as I described in Post #2 of this topic: dragging the entire, opened disk image rather than the Manager application to the Applications folder. Is there any chance you accidentally did this?

I normally download to my desktop. But as an experiment, I just downloaded to the Downloads folder. That made no difference. The latest update installed correctly following the procedure in the Guide, exactly as it does when the disk image is downloaded to the desktop. (Since @plasmaman’s remedy was to drag to the desktop, then to the Applications folder, I thought that might make some difference, but it does not.)

All - I saw mcgood’s post and Tut’s reply so did the upgrade routine to 18.11.66 this morning.
Download DMG folder from Manager site and saved to desktop.
Open DMG and dragged Manager App icon into Applications folder. This action creates an alias in the Applications folder, so when running the programme from the Applications folder it opens the DMG folder first.
But, as before if I drag the Manager App from the DMG folder to the desktop, and then from the desktop to the Applications folder, it does not create the alias and runs as it should without opening the DMG folder.
Maybe something to do with iCloud perhaps, as when I drag the Manager App from the desktop to the Applications folder it tells me I am removing the App from iCloud…

1 Like

Very interesting. I would look under your browser preferences to see where your actual download location is. If using Safari, this under Safarai > Preferences > General.

Safari saves to location Downloads folder
ie path is Macintosh HD⁩ ▸ ⁨Users⁩ ▸ my usual system username▸ downloads

Try changing the downloads location temporarily to your desktop to see if that makes any difference. As I said, that’s my normal preference, but changing it back to the default Downloads folder didn’t make any difference. If this makes a difference for you, that might point toward some other issue, such as iCloud preferences. (I don’t put any Manager files on iCloud. It seems as though you might be doing that.)

Hi Tut,

The closest I can get to replicating this problem is as I described in Post #2 of this topic: dragging the entire, opened disk image rather than the Manager application to the Applications folder. Is there any chance you accidentally did this?

No, I did not. I repeated the whole process today (18.11.64) with exactly the same result. Note that the location of my Downloads folder is ~/Users/mcgood/Download, and there is no iCloud involvement here. I have not experienced this phenomenon with any other application before.

@mcgood, where are you downloading from? The version available on the official site has ben 18.11.66 since at least December 7, possible a little before. (That’s when I installed it.)

Did you temporarily try changing your download location like I suggested? Whether you’ve experienced this with any other application is irrelevant. I’m trying to determine whether it makes a difference with installing Manager’s bundle.

OK, downloaded 18.11.16 from
(as before) to my Downloads folder; double-clicked Manager.dmg; dragged to blue Applications folder in Dock: same result – creates alias.

Deleted this alias, and dragged from Manager volume to Applications folder in Finder: bingo, full size (74.4 MB) app appears, which can be successfully launched from Finder folder or Dock folder.

So, alias outcome seems to be associated with dragging to Dock Applications folder. Any other explicit copy method works fine.

It turns out you were not following the Guide, which clearly says to drag the app to the Applications folder. The icon in the Dock is not the Applications folder. It is an alias itself.

Well, the Guide is not that prescriptive. It says:

“Drag the Manager application icon from the Manager disk folder into the Applications folder on the computer.”

The only place I see such a large blue icon is in the dock; I always have a list view in Finder. So perhaps you can understand my error, and perhaps the guide should warn about the “dock trap”.