Customer Tab - Why does Uninvoiced column only show sometimes?

My workflow for creating invoices for billable time is the following,

  1. Enter the Billable Time, make sure to select the correct Customer.
  2. Go to Customers tab, sort by Uninvoiced by clicking the column heading.
  3. Click the amount to start creating an invoice.

The problem is that if there isn’t a Customer with Uninvoiced amount on the first page, the Uninvoiced column is not shown.

This means I have to search for the customer and then click the Uninvoiced time.

Is there a reason that the Uninvoiced column is not shown all the time?

Empty columns are always suppressed. That’s a basic feature of Manager. You can override that by displaying all records on one page. Click the button at bottom left of the list. This feature exists to speed up loading of large data bases.

1 Like

Can I set the default to how many pages I want to display? Or do I need to change in each screen?

Try it and see.

1 Like

This works to allow me to see all of the uninvoiced customers without searching for them.

However, my followup question was asking about how to set this view as the default view so I don’t have set it each time I navigate to the Customers screen.

Yes, and what happened when you tried?

It does not save my setting. It makes me set it every time I navigate to the Customers screen.

Is there something I am missing?

I may have fixed it by trying to get a screen capture of the behavior.

To get ready for the capture, I opened my test company and added 100+ customers, and then added a few uninvoiced billable time entries to the customers not on first page. The initial view did not show the Uninvoiced column, even when there were uninvoiced entries, so I used the “Edit columns” button to enable the Uninvoiced column. This showed the Uninvoiced column even when the page size was set to 50 and there were no uninvoiced values for the customers listed. And the change was persistent through screen changes and application restarts.

I backed out of my test company and into my primary company and checked and unchecked the checkbox for Uninvoiced column. This seems to have reset the functionality and the Uninvoiced column is persistent now.

So that’s new behavior.

@dr00bie in near future, you will be able to create pre-configured views for each tab. So if you want a view where it shows only customers with Uninvoiced amounts, it will be possible without manually configuring the view each time.

@Tut I figured that it was behaving differently for others from your responses to me, like it should work. So I wanted to show the behavior I was seeing, that it was not showing the column.

@lubos looking forward to it! This works a lot better now that I have somehow reset the functionality by unchecking and rechecking the Uninvoiced checkbox in “Edit Columns”. Maybe a feature or update was not applied until I did that? I do not recall being able to edit the columns 4+ years ago when I set this company up.

Edit Columns is a new concept being introduced only a month ago. See:

1 Like